[Freeswitch-dev] **/usr/local/freeswitch/mod/mod_spidermonkey.so: undefined symbol: SSL_connect**

Vitalii Colosov vetali100 at gmail.com
Fri Mar 19 04:25:45 PDT 2010

Found the following in config.log

configure:20286: checking openssl/tls1.h usability
configure:20286: gcc -c -g -O2  conftest.c >&5
In file included from conftest.c:127:
/usr/include/openssl/tls1.h:125: error: expected ';', ',' or ')' before '*'
/usr/include/openssl/tls1.h:126: error: expected ';', ',' or ')' before '*'
configure:20286: $? = 1
configure: failed program was:
| /* confdefs.h */

My tls1.h in /usr/include had the following lines 125,126:
const char *SSL_get_servername(const SSL *s, const int type) ;
int SSL_get_servername_type(const SSL *s) ;
Strange, these particular lines do not look wrong for me.

I found same file in OpenSSL source and put instead of my file.
It gives me the same compilation problem.

Will compile FS without SSL.

Any idea why this happens?

Thank you,

2010/3/19 Vitalii Colosov <vetali100 at gmail.com>

> Hi,
> I've built last trunk today and am getting this error during FreeSWITCH
> loading.
>    **/usr/local/freeswitch/mod/mod_spidermonkey.so: undefined symbol:
> SSL_connect**
> Same error for mod_xml_cdr...
> Looks like it was fixed as per the following:
> http://jira.freeswitch.org/browse/FSBUILD-250
> But error exists for me and I am not sure how to resolve it.
> *I tried to rebuild again and noticed the following warning (never seen
> this before...):*
> checking for curl... no
> checking for tgetent in -lncurses... yes
> checking openssl/tls1.h usability... no
> checking openssl/tls1.h presence... yes
> configure: WARNING: openssl/tls1.h: present but cannot be compiled
> configure: WARNING: openssl/tls1.h:     check for missing prerequisite
> headers?
> configure: WARNING: openssl/tls1.h: see the Autoconf documentation
> configure: WARNING: openssl/tls1.h:     section "Present But Cannot Be
> Compiled"
> configure: WARNING: openssl/tls1.h: proceeding with the compiler's result
> configure: WARNING:     ## --------------------------------- ##
> configure: WARNING:     ## Report this to BUG-REPORT-ADDRESS ##
> configure: WARNING:     ## --------------------------------- ##
> checking for openssl/tls1.h... no
> configure: WARNING: OpenSSL include files were not found
> *Can this be the reason of error and (newbie question) how can I find
> OpenSSL include files?*
> Thank you,
> vIT
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-dev/attachments/20100319/9399363a/attachment.html 

More information about the FreeSWITCH-dev mailing list