[Freeswitch-dev] **/usr/local/freeswitch/mod/mod_spidermonkey.so: undefined symbol: SSL_connect**

Vitalii Colosov vetali100 at gmail.com
Fri Mar 19 03:51:08 PDT 2010


I've built last trunk today and am getting this error during FreeSWITCH
   **/usr/local/freeswitch/mod/mod_spidermonkey.so: undefined symbol:
Same error for mod_xml_cdr...

Looks like it was fixed as per the following:

But error exists for me and I am not sure how to resolve it.

*I tried to rebuild again and noticed the following warning (never seen this

checking for curl... no
checking for tgetent in -lncurses... yes
checking openssl/tls1.h usability... no
checking openssl/tls1.h presence... yes
configure: WARNING: openssl/tls1.h: present but cannot be compiled
configure: WARNING: openssl/tls1.h:     check for missing prerequisite
configure: WARNING: openssl/tls1.h: see the Autoconf documentation
configure: WARNING: openssl/tls1.h:     section "Present But Cannot Be
configure: WARNING: openssl/tls1.h: proceeding with the compiler's result
configure: WARNING:     ## --------------------------------- ##
configure: WARNING:     ## Report this to BUG-REPORT-ADDRESS ##
configure: WARNING:     ## --------------------------------- ##
checking for openssl/tls1.h... no
configure: WARNING: OpenSSL include files were not found

*Can this be the reason of error and (newbie question) how can I find
OpenSSL include files?*

Thank you,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-dev/attachments/20100319/cff61100/attachment.html 

More information about the FreeSWITCH-dev mailing list