[Freeswitch-users] [Solved] Callgroup keeps ringing after answer - changed from shared extensions

S. Scott 8f27e956 at gmail.com
Tue Feb 5 00:04:03 MSK 2013

May be/may not be your issue/solution, but certain SPA config/use
conditions result in the SPA utilizing ("listening" -- additionally -- on)
a second sip signaling port, which is usually prime+2; therefore, (default)
prime 5060, then secondary would be 5062.  The fs config would then need to
"aim" the secondary features/functions at spa:5062.  I once ran into this
with a Panasonic switch and the SPA.  Regardless, though, they are a pain.

iThing:  Big thumbs & little keys. Please excuse typo, spelling and grammar
errors • Thought of the Day – "With all this manure, there must be a pony
in here somewhere.”

On 2013-02-04, at 15:44, Mario G <mario_fs at mgtech.com> wrote:

I am sharing this "hair puller" problem in case someone else runs into it.
It took 9 months to resolve. I tried to find something different in traces
for good/bad calls  but nothing. Updated FreeSwitch stable and head many
times, no luck. I posted here in April but no responses and found only 1
similar issues searching the web.

*Intermittent Problems*: Started when all SPA962s changed from shared IDs
to unique IDs. *1* - A call is answered and heard  but other extensions
keep ringing. *2* - A call is answered but there is silence and other
extensions keep ringing, pick up one by one, each silence.

*Solution*: Replaced Cisco/Linksys SPA962s with Yealink T32s (UDP) and
iPads (TCP) and have not seen this problem for a 2 months so we're pretty
sure it's gone. BTW we really like the T32s (bought based on comments
here). Yes I checked and tried many different SPA962 settings, good
Mario G

On Apr 16, 2012, at 2:30 PM, Mario G wrote:

Been at this for 3 weeks now, hope someone can help.... This started after
replacing shared extensions with unique users and updating from an early
2011 git.

Ring group via "pointer" works fine as it always has. However, answer via
callgroup variable intermittently (30-40%) leaves one or mores phone
ringing even though the the call was answered at another extension. The
darn thing is that I can't reproduce it myself to get a trace. Any
help/suggestions greatly appreciated. Phones are SPA962 (UDP) and Bria on
iPad (TCP, same problems) and they all stopped ringing when they shared IDs.
Mario G

default.xml ring-group has (abbreviated to save space)------------------:
<group name="main">
  <user id="100" type="pointer"/>
  <user id="101" type="pointer"/>
..... more users

        <group name="work">
  <user id="200" type="pointer"/>
  <user id="201" type="pointer"/>

  <user id="101">
      <param name="password" value="$${default_password}"/>
      <variable name="voicemail_domain" value="xxxxxx.com"/>
      <variable name="toll_allow" value=
      <variable name="user_context" value="default"/>
      <variable name="effective_caller_id_name" value="Front Desk"/>
      <variable name="effective_caller_id_number" value="101"/>
      <variable name="outbound_caller_id_name" value=
      <variable name="outbound_caller_id_number" value=
      <!-- callgroup needed to stop ringing on call pickup  -->
      <variable name="callgroup" value="main"/>

Bridge command-----------------:
    <extension name="xxphone">
      <condition field="destination_number" expression="^2920$">
        <action application="bind_meta_app" data="1 b s
execute_extension::dx XML features"/>
        <action application="bind_meta_app" data="2 b s
        <action application="bind_meta_app" data="3 b s
execute_extension::cf XML features"/>
        <!--  Set the sayname variable with the callers name -->
        <action application="execute_extension" data="2925 XML default"/>
        <!-- Next lines allow control after bridge timeout and hangup after
bridge -->
        <action application="set" data="hangup_after_bridge=true"/>
        <action application="set" data="continue_on_fail=true"/>
<action application="set" data=
        <!-- ring extensions only for ## seconds -->
        <action application="bridge" data=


Professional FreeSWITCH Consulting Services:
consulting at freeswitch.org

Official FreeSWITCH Sites

FreeSWITCH-users mailing list
FreeSWITCH-users at lists.freeswitch.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20130204/be515f42/attachment-0001.html 

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list