[Freeswitch-users] Dialplan not matching

David Villasmil david.villasmil.work at gmail.com
Tue Sep 21 18:50:32 UTC 2021

Hello all,

I have the following condition:

<action application="log" data="ERR UUID: ${uuid} = ${conference_name}"/>
<condition field="${cond(${uuid} == ${conference_name} ? YES : NO)}"

The log properly prints both variables:

mod_dptools.c:1879 UUID: 7d736b08-212b-4ac2-abb3-a5e738306fb5 =

they're exactly the same, and still condition function fails:

Regex (FAIL) [conf_destination_recur_1] ${cond(${uuid} ==
${conference_name} ? YES : NO)}(-ERR) =~ /^YES$/ break=on-false

I also tried a simple condition like

<condition field="${uuid}" expression="${conference_name}">

and still no match...


Thanks guys

David Villasmil
email: david.villasmil.work at gmail.com
phone: +34669448337
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20210921/8d735869/attachment-0001.html>

More information about the FreeSWITCH-users mailing list