[Freeswitch-users] rfc 2833 not offered on outbound leg in bridge scenario with FS 1.6.7 (worked properly in FS 1.6.6)

Dave Horton daveh at beachdognet.com
Fri Apr 15 07:40:14 MSD 2016

I’m running into a problem on v1.6.7 with something that seemed to work properly on v1.6.6, and I am wondering if this is a known bug.

I have an application that receives an incoming call and bridges it to an outbound destination.  Where there is RFC 2833 offered on the A leg for dtmf I want that to offer that on the B leg as well.  
I have defined late-negotiation=true on my sip profile.

In v1.6.6 (specifically, User agent header identifies as 1.6.6+git~20160111T201612Z~d2d0b3283a~64bit) this worked as expected.

In v1.6.7 (specifically, User agent header identifies as 1.6.7+git~20160401T134007Z~f0c3870be3~64bit) it doesn’t.
The SDP offered on the B leg does not include RFC 2833 even though the A leg offered it.

Is this a known bug?  If so, is there a patch?

If not, I can provide more information (pastebin logs, etc) to help troubleshoot.  Please let me know what would be most useful to see.

Join us at ClueCon 2016 Aug 8-12, 2016
More information about the FreeSWITCH-users mailing list