[Freeswitch-users] FreeSwitch Error: "username param is REQUIRED!"

A E G all.eforums at gmail.com
Fri Aug 3 02:58:33 MSD 2012

I don't see anywhere where this " alcazarnetworks-outbound " gateway is
even being loaded. Nor do I see where FS would figure out how to reach this
alcaz-outbound realm. Are these being looked up from DNS? If not, then how
do you propose sofia finds the IP to contact this gateway on? I think with
the bridge command you might have to still tell it the IP. If you tell it
the IP, then why is the definition of the gateway needed if you're not

Haha sorry I'm not all that of an expert at FS either so maybe someone more
knowledgeable can respond to this and help us both.

I think what you need to run, as mentioned previously is

fs at internal>sofia profile external gwlist up <-- this should show you the
gateways that are loaded and ready (I think)

if you don't see your  alcazarnetworks-outbound  gateway there, try running

fs at internal>sofia profile external rescan reloadxml <-- this should rescan
your gateways in the directory and you should see alcazarnetworks-outbound
load up OR it should give you some error as to why it can't load it up.
Also, don't forget to include the </gateway> in the config file. I'm
surprised that this doesn't show up as an error in the console when you
load it up.


On Thu, Aug 2, 2012 at 5:22 PM, Sazzad <sazzadbinkamal at gmail.com> wrote:

> This is odd then.
> (@_@)
>> I don't know if the issue is occuring where you think
>> it is. Do you have any other gateways setup in profile external?
> Nope!
>> Can you post the output of 'sofia status' with minimal changes, please?
> Sure, I can. Though I don't think it'll be of much help to you. Here<http://pastebin.freeswitch.org/19631>it is.
>> For reference, the following definitely works for a provider which does
>> not require username/password (i.e. IP authentication only), I've only
>> obfuscated the actual IP address from the realm in this example:
>>    <include>
>>      <gateway name="provider">
>>        <param name="username" value="not-used"/>
>>        <param name="password" value="not-used"/>
>>        <param name="realm" value=""/>
>>        <param name="register" value="false"/>
>>        <param name="caller-id-in-from" value="true"/>
>>      </gateway>
>>    </include>
> I see. Hmm, but Alcazar support adviced to use Freeswitch bridge command
> to point to ip. Probably it is same as Asterisk bridge()?! And it
> definitely is not seeming like a cli command rather an application to be
> used in dialplan, I guess. By the way, I registered Alcazar for outbound
> termination.
> May be this context may help you find out some reason:
> I'm trying to use Newfies <http://newfies-dialer.org> dialer. Plivo<http://plivo.com>has been installed on the server, so we'll not be using their API (or
> sending request to their cloud server).
> After a fresh install I simply did the following according to Newfies doc:
> 1. copy-paste the sip_profile/external/example.com to alcazarnetworks.com
> 2. change relevant fields, EXACTLY same as you provided in the above
> example. EXCEPT "realm" and "caller-id-in-form" fields. I used real
> username and password provided by Alcazar by the way.
> 3. Run command : "sip profile external restart reloadxml" and got the
> error!
> 4. So I tried it on my local machine (which is not registered with
> Alcazar) and got the same error!
> That's all I can tell.
> --
> Sincerely,
> Sazzad Bin Kamal
> _________________________________________________________________________
> Professional FreeSWITCH Consulting Services:
> consulting at freeswitch.org
> http://www.freeswitchsolutions.com
> Official FreeSWITCH Sites
> http://www.freeswitch.org
> http://wiki.freeswitch.org
> http://www.cluecon.com
> Join Us At ClueCon - Aug 7-9, 2012
> FreeSWITCH-users mailing list
> FreeSWITCH-users at lists.freeswitch.org
> http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
> UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
> http://www.freeswitch.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20120802/386e02ba/attachment.html 

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list