[Freeswitch-users] FreeSwitch Error: "username param is REQUIRED!"

Sazzad sazzadbinkamal at gmail.com
Fri Aug 3 01:22:02 MSD 2012

> This is odd then.


> I don't know if the issue is occuring where you think
> it is. Do you have any other gateways setup in profile external?


> Can you post the output of 'sofia status' with minimal changes, please?

Sure, I can. Though I don't think it'll be of much help to you.
Here<http://pastebin.freeswitch.org/19631>it is.

> For reference, the following definitely works for a provider which does
> not require username/password (i.e. IP authentication only), I've only
> obfuscated the actual IP address from the realm in this example:
>    <include>
>      <gateway name="provider">
>        <param name="username" value="not-used"/>
>        <param name="password" value="not-used"/>
>        <param name="realm" value=""/>
>        <param name="register" value="false"/>
>        <param name="caller-id-in-from" value="true"/>
>      </gateway>
>    </include>

I see. Hmm, but Alcazar support adviced to use Freeswitch bridge command to
point to ip. Probably it is same as Asterisk bridge()?! And it definitely
is not seeming like a cli command rather an application to be used in
dialplan, I guess. By the way, I registered Alcazar for outbound

May be this context may help you find out some reason:

I'm trying to use Newfies <http://newfies-dialer.org> dialer.
Plivo<http://plivo.com>has been installed on the server, so we'll not
be using their API (or
sending request to their cloud server).

After a fresh install I simply did the following according to Newfies doc:

1. copy-paste the sip_profile/external/example.com to alcazarnetworks.com
2. change relevant fields, EXACTLY same as you provided in the above
example. EXCEPT "realm" and "caller-id-in-form" fields. I used real
username and password provided by Alcazar by the way.
3. Run command : "sip profile external restart reloadxml" and got the error!
4. So I tried it on my local machine (which is not registered with Alcazar)
and got the same error!

That's all I can tell.

Sazzad Bin Kamal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20120803/96b3e2de/attachment-0001.html 

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list