[Freeswitch-users] Binding to virtual interface (ipsec vpn)

Brian West brian at freeswitch.org
Mon Oct 11 10:33:52 PDT 2010

If you set the IP in sip-ip and rtp-ip that is abound to eth0:3 then it should bind to that interface/ip and use that... I haven't see anything out of the usual when doing this.

Show me your profile config and the output of ifconfig -a


On Oct 11, 2010, at 4:46 AM, Nicolas Brenner wrote:

> Hello everyone,
> I'm having trouble binding FS to another ip on a virtual interface (eth0:3). The virtual interface's ip address is the gateway to an ipsec vpn, and the only way to access this voip provider's sip server, is through the vpn.
> I tried setting up an additional sip profile, with rtp-ip and sip-ip as the virtual interface's ip, but when I do that, no packets are sent at all when trying to make a call with originate through the cli (according to tcpdump). I tried also setting ext-rtp-ip and ext-sip-ip to the same virtual interface's ip, but nothing happened, still no packets being sent (according to tcpdump) when trying to make a call. Finally I tried only setting ext-rtp-ip and ext-sip-ip to the virtual interface's ip, and leave rtp-ip and sip-ip to $${local_ip_v4}, then tcpdump started seeing some traffic (when trying to originate a call) which I was able to capture. When I loaded the trace on wireshark though, I noticed the source ip being used to send all the (sip) packets, is the one from eth0 (public ip), and not eth0:3's ip (private ip for vpn).
> Has anyone had any similiar experiences? how were you able to solve it?
> Thanks for your help!
> Nico

More information about the FreeSWITCH-users mailing list