[Freeswitch-users] Binding to virtual interface (ipsec vpn)

Nicolas Brenner nico at clickfono.com
Mon Oct 11 02:46:11 PDT 2010

Hello everyone,

I'm having trouble binding FS to another ip on a virtual interface (eth0:3).
The virtual interface's ip address is the gateway to an ipsec vpn, and the
only way to access this voip provider's sip server, is through the vpn.

I tried setting up an additional sip profile, with rtp-ip and sip-ip as the
virtual interface's ip, but when I do that, no packets are sent at all when
trying to make a call with originate through the cli (according to tcpdump).
I tried also setting ext-rtp-ip and ext-sip-ip to the same virtual
interface's ip, but nothing happened, still no packets being sent (according
to tcpdump) when trying to make a call. Finally I tried only
setting ext-rtp-ip and ext-sip-ip to the virtual interface's ip, and leave
rtp-ip and sip-ip to $${local_ip_v4}, then tcpdump started seeing some
traffic (when trying to originate a call) which I was able to capture. When
I loaded the trace on wireshark though, I noticed the source ip being used
to send all the (sip) packets, is the one from eth0 (public ip), and not
eth0:3's ip (private ip for vpn).

Has anyone had any similiar experiences? how were you able to solve it?

Thanks for your help!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20101011/d15c7490/attachment.html 

More information about the FreeSWITCH-users mailing list