[Freeswitch-users] Lua and database access to core_db

Jon Bruel jbr at consiglia.dk
Tue Dec 8 10:00:54 PST 2009

Point taken Anthony. Naturally you are not going to work for me for free.

But I'm a bit confused about the statement that "I'm rude". That's not my purpose to be. And I certainly do hope that this is not just a question of a cultural clash between an elderly man with a Phd in black holes from a European background and a young American FS genius.

But frankly, I did believe that focus regarding changes and new developments was somewhat guided by the input you get from the users list, including changes which makes the FS easier to access for newbies, but maybe I'm wrong.

That's my last comment, hope we can continue the exchange of views in a good spirit.

Jon Brüel
Consiglia Telecommunications
DK-2960 Rungsted Kyst
Tel: +45 45 16 1000
Mob: +45 26 15 30 60
CVR: 27047882

From: freeswitch-users-bounces at lists.freeswitch.org [mailto:freeswitch-users-bounces at lists.freeswitch.org] On Behalf Of Anthony Minessale
Sent: 8. december 2009 17:28
To: freeswitch-users at lists.freeswitch.org
Subject: Re: [Freeswitch-users] Lua and database access to core_db

One last bit of free consulting advice for you:

You are again being rude because you want us to work for you for free.
The code is free sir, the support here is voluntary and based on our willingness to help and comments like that are all it takes to get us to ignore you completely.

On Tue, Dec 8, 2009 at 5:46 AM, Jon Bruel <jbr at consiglia.dk<mailto:jbr at consiglia.dk>> wrote:
I got the combination Lua with direct access to the core Sqlite database to work. Hurray, maybe I'm not as stupid as A.M II hints...
The problem was that Lua did not "like":

    require "luasql.sqlite"
    env = luasql.sqlite()
    con = assert(env:connect("/usr/local/freeswitch/db/core.db"))

After changing it to

    require "luasql.sqlite3"
    env = luasql.sqlite3()
    con = assert(env:connect("/usr/local/freeswitch/db/core.db"))

And seeing that there was a symlink in one of the right directories called with the name: sqlite3.so, it worked.

Changing the core db into a MySQL via ODBC caused some problems even after it seemed to work. For instance, console help caused an error with an error description indicating that a SQL SELECT query including the reserved word key has been fired.

It this problem likely to be solved if I used another version of the MySQL?

Jon Brüel
Consiglia Telecommunications
DK-2960 Rungsted Kyst
Tel: +45 45 16 1000
Mob: +45 26 15 30 60
CVR: 27047882

FreeSWITCH-users mailing list
FreeSWITCH-users at lists.freeswitch.org<mailto:FreeSWITCH-users at lists.freeswitch.org>

Anthony Minessale II

FreeSWITCH http://www.freeswitch.org/
ClueCon http://www.cluecon.com/
Twitter: http://twitter.com/FreeSWITCH_wire

AIM: anthm
MSN:anthony_minessale at hotmail.com<mailto:MSN%3Aanthony_minessale at hotmail.com>
GTALK/JABBER/PAYPAL:anthony.minessale at gmail.com<mailto:PAYPAL%3Aanthony.minessale at gmail.com>
IRC: irc.freenode.net<http://irc.freenode.net> #freeswitch

FreeSWITCH Developer Conference
sip:888 at conference.freeswitch.org<mailto:sip%3A888 at conference.freeswitch.org>
iax:guest at conference.freeswitch.org/888<http://iax:guest@conference.freeswitch.org/888>
googletalk:conf+888 at conference.freeswitch.org<mailto:googletalk%3Aconf%2B888 at conference.freeswitch.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20091208/7b83ab6d/attachment-0002.html 

More information about the FreeSWITCH-users mailing list