[Freeswitch-users] Question on using java_mod

damjan at ecntelecoms.com damjan at ecntelecoms.com
Mon Nov 10 05:53:54 PST 2008

No, not the path to *freeswitch.jar*, use the path to *your* JAR
containing the class.


> Thanks Klaus,
> Tried that as well, if I use a full path for PhoneTest then I get same
> error as earlier.
> If I call only PhoneTest without any path
> (/usr/local/freeswitch/scripts/freeswitch.jar PhoneTest arg1 arg2..) then
> I get:
> Exception in thread "Thread-2" java.lang.ClassNotFoundException: PhoneTest
>        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)        at
> java.security.AccessController.doPrivileged(Native Method)        at
> java.net.URLClassLoader.findClass(URLClassLoader.java:188)        at
> java.lang.ClassLoader.loadClass(ClassLoader.java:306)        at
> java.lang.ClassLoader.loadClass(ClassLoader.java:251)        at
> java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)        at
> java.lang.Class.forName0(Native Method)        at
> java.lang.Class.forName(Class.java:242)        at
> org.freeswitch.Launcher.launch(Launcher.java:65)
> It's a same error message if I leave the full path off from freeswitch.jar
> as well. There must be something what I have not understood about the
> documentation here..
>     N
> You might want to specify not only the class name, but also its package
> name as well as the jar file that contains it. <action application="java"
> data="/path/to/file.jar fully.qualified.class.name arg1 arg2 arg3"/>
> Klaus.
> From: i.mkmo at hotmail.comTo: freeswitch-users at lists.freeswitch.orgSubject:
> Question on using java_modDate: Sun, 9 Nov 2008 21:28:23 +0800
> Hey, I've been testing the usage of mod_java and reading Freeswitch
> documentation but been having some problems which I think might even be
> something very simple which I've missed. Hope some could give a
> hint..mod_java installation has gone through successfully and mod_java.so
> is compiled and installed.  Configuration files java.conf.xml and dialplan
> are configured as instructed in
> http://wiki.freeswitch.org/wiki/JavaCompilation of the Java example in the
> same page is successful (CLASSPATH included freeswtich.jar of course).
> Problem comes when I try to initiate the script via dialplan - that is I'm
> trying to make a call to an extension which then calls this example script
> (dialplan says: <action application="java" data="PhoneTest arg1 arg2
> arg3"/>). Error message gives me: Exception in thread "Thread-1"
> java.lang.ClassNotFoundException: /usr/local/freeswitch/scripts/PhoneTest
>        at java.lang.Class.forName0(Native Method)        at
> java.lang.Class.forName(Class.java:242)         at
> org.freeswitch.Launcher.launch(Launcher.java:65) I presume this means that
> the script is called invalid manner?  I've been trying to call the
> PhoneTest with full path, locating it together with freeswitch.jar,
> creating a directory PhoneTest just name it.Documentation does not say if
> the Java binary needs to be in certain location or not - is there
> amandatory location for it? What else am I doing wrong?       My system is
> running in CentOS 5, Java version JDK1.5.0_16 so the unstability described
> in Wiki should not be a reason.        Nic
> Enrich your blog with Windows Live Writer. Windows Live Writer
> _________________________________________________________________
> NEW! Get Windows Live FREE.
> http://www.get.live.com/wl/all_______________________________________________
> Freeswitch-users mailing list
> Freeswitch-users at lists.freeswitch.org
> http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
> UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
> http://www.freeswitch.org

More information about the FreeSWITCH-users mailing list