[Freeswitch-users] Audio fax via FreeSWITCH in Default media mode

Loi Dang loidang at hoiio.com
Thu Jun 27 07:21:54 UTC 2019

Hi all, i'm using FS in the middle of a fax call in Default media mode
without loading mod_spandsp.so
`t38-passthru` profile param is enabled, and `fax_enable_t38` channel
variables are exported.
`Asterisk SendFax() -> FreeSWITCH -> Asterisk ReceiveFax()` call flow
applied, the codec ulaw was used in all cases
All Faxes are succeeded if T.38 involved but when either party is
configured intentionally NOT to support T.38, g711 fax was used as expected
but nearly all faxes failed (a very few fax calls success in audio mode).
I tried removing FS out of the path and the g711 faxes was working fine

I'm not sure why so i tweaked some rtp options in FS without knowing very
well what they do

    <param name="auto-rtp-bugs" value="clear"/>
    <param name="rtp-autofix-timing" value="false"/>
    <param name="rtp-rewrite-timestamps" value="false"/>
when i tried
`<param name="rtp-notimer-during-bridge" value="true"/>`, the audio faxes
has higher rate of success, but the T.38 failed completely.

My version is 1.6.17, tried 1.8.6 without any luck

any idea or experience for making g711 fax work with FS in my case?
thanks thanks

Also tried Proxy media mode to let FS stayed in the path but do not touch
the stream,, g711 faxes was working properly, so i guess there was some
tweaks by FS default media mode into the rtp stream causing the g711 fax

Loi Dang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20190627/2b64eaa1/attachment.html>

More information about the FreeSWITCH-users mailing list