[Freeswitch-users] iOS 12.3 / FreeSWITCH m-lines ordering issue

David P davidswalkabout at gmail.com
Thu Jun 6 02:43:33 UTC 2019

Hi Chad,

When you've tested verto with Safari/iOS (say, v12), have you seen a call
answered and then immediately hangup from the FS side? I get that

Here's what I've tried:
1. We use the latest commercial release of FS, 20.19.4, on debian stretch
2. I merged your fix to jquery.FSRTC.js into ours, which has only minor
changes from the tip of FS' repo
3. I tried our verto app on iOS 12 (using AWS Device Farm because I don't
have Apple devices)
4. freeswitch.log shows verto.bye immediately after verto.answer, even in
the same millisecond! I've attached a snippet of the log showing this.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20190606/43978154/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: silentForIOS_forSharingOnMailingList.log
Type: application/octet-stream
Size: 4517 bytes
Desc: not available
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20190606/43978154/attachment.obj>

More information about the FreeSWITCH-users mailing list