[Freeswitch-users] fs_cli under Windows and cygwin, no prompt

Peter Steinbach lists at telefaks.de
Fri Feb 5 00:20:26 MSK 2016

I have inherited a Freeswitch installation on a Windows server, which I
remotely manage with cygwin and ssh.

This worked more or less nicely so far. But today I cannot manage
Freeswitch via ssh with fs_cli anymore. I restarted the hardware, but no
I can run fs_cli.exe, and I see the Freeswitch messages, but I do
__not__ get a prompt. When I try to enter characters, nothing happens.

On the machine itself, when I open a console and start cygwin,
fs_cli.exe works as expected with prompt. But not via ssh. But
fs_cli.exe -x "command" works via ssh, so login to Freeswitch should be
fine in general.

What I understand is, that fs_cli connects to Freeswitch via port 8021.
So when seeing FS messages, I expect that the connection is already
fine, right?

I also tried to connect via telnet to port 8021. This works in the local
cygwin shell (get an auth request), but not via remote ssh shell (telnet
terminates without message).

I am puzzled. Anybody has a clue, why I do not have a prompt and where
to search?

With kind regards
Peter Steinbach 

Telefaks Services GmbH
mailto:lists (att) telefaks.de
Internet: www.telefaks.de

Join us at ClueCon 2016 Aug 8-12, 2016
More information about the FreeSWITCH-users mailing list