[Freeswitch-users] Aastra phone registration lost

Philippe Sultan philippe.sultan at gmail.com
Wed Feb 9 18:46:29 MSK 2011

Hello to the FreeSWITCH users,

I'm experiencing problems registering an Aastra 6731i phone to
FreeSWITCH. The registration process itself works fine, but the phone
never re-registers to FS after the expiration time specified in the
expires paramater set in the Contact SIP Header Field. And therefore
becomes unreachable from FS after some time.

The phone seems to be buggy because it simply ignores the value given
in the expires parameter. Testing with Asterisk, the phone remains
accessible, because Asterisk adds an Expires HF in addition to the
expires param in the Contact HF.

Did anyone observed what's described here? I've tested several Aastra
firmwares with the same result. I have also tried to set the
registration expiration time on the phone itself without success.

I believe I can cope with this situation by adding an Expires HF from
the (SIP Express Router) proxy that stays between the phone and FS,
but I'm sure there's a simpler way to get a proper registation

I'm using FreeSWITCH 1.0.6 (that comes along with the Blue.box GUI).

Kind regards,


More information about the FreeSWITCH-users mailing list