[Freeswitch-users] My fs_cli stopped working, can you help me please?

Milena testeador01 at gmail.com
Sat Jan 24 05:22:12 PST 2009

Well, telnet works, what else could it be?

another thing i remember doing before the fs_cli stopped working was
installing TCAPI and getting it to work, but i didn't change any config
files or anything other than what it says in the instalation instructions;

I don't mind so much about replicating the issue and figuring out how did it
get damaged, what I really want to know now is how to make it work again
cause even reconfiguring/installing fs doesn't fix it and the truth is, the
fs_cli is comfortable; any idea on how to fix it other than starting a fresh
install of fs from a new os instalation?

Thank you!

My telnet output:
-bash-3.2# telnet localhost 8021
Connected to localhost.localdomain (
Escape character is '^]'.
Content-Type: auth/request

auth <my password>

Content-Type: command/reply
Reply-Text: +OK accepted


Content-Type: command/reply
Reply-Text: +OK bye

Content-Type: text/disconnect-notice
Content-Length: 70

Disconnected, goodbye!
See you at ClueCon http://www.cluecon.com/ !!!
Connection closed by foreign host.


*Michael Collins wrote:*

just for kicks, can you try a raw telnet session, just to make sure
the the event socket is working properly?
telnet localhost 8021
auth ClueCon (press enter twice)

If you get something like this:
h-3.2# telnet localhost 8021
Trying ::1...
telnet: connect to address ::1: Connection refused
Trying fe80::1...
telnet: connect to address fe80::1: Connection refused
Connected to localhost.
Escape character is '^]'.
Content-Type: auth/request

auth ClueCon

Content-Type: command/reply
Reply-Text: +OK accepted

Then the event socket stuff is working. To exit out, type "exit" then
enter twice. Let us know what happens.

On Fri, Jan 23, 2009 at 2:14 PM, Milena <testeador01 at gmail.com
*>* I use the stable version of fs 1.0.2 testing out different options of
*>* configuration;
*>* Last thing I was doing was trying to fix some issues with dingaling-google
*>* talk cause i hear no audio at all from an external ip, and i still didnt get
*>* it to work;
*>* so i tried deleting the sofia_* files on the folder db/ as suggested on
*>* another thread about nat related issues (oops?), and then restarting fs.
*>* After this, trying to execute bin/fs_cli doesn't work anymore; it tries to
*>* connect cause i get the output on the box:
*>* 2009-01-23 16:23:59 [DEBUG] mod_event_socket.c:1791 listener_run()
*>* Connection Open from
*>* 2009-01-23 16:23:59 [DEBUG] mod_event_socket.c:1914 listener_run() Session
*>* complete, waiting for children
*>* 2009-01-23 16:23:59 [DEBUG] mod_event_socket.c:1938 listener_run()
*>* Connection Closed
*>* but on the console where im trying to run the cli nothing happens,
*>* I tried rebooting the machine; i tried with freeswitch make current, it
*>* didn't fix it; i tried all the way from configure to make and make install
*>* and it didn't fix my problem either.
*>* What should i run or change on the configurations to fix this?
*>* Thank you very much.
*>* _______________________________________________
*>* Freeswitch-users mailing list
*>* Freeswitch-users at lists.freeswitch.org
*>* http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
*>* UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
*>* http://www.freeswitch.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20090124/fbfc35f9/attachment-0002.html 

More information about the FreeSWITCH-users mailing list