[Freeswitch-users] Using mod_managed Linux/Mono

Adam Long ajlong at worldlink.net
Thu Jan 15 10:04:44 PST 2009

Thanks Michael, that did get me a little further.


I renamed mod_managed_lib.dll to FreeSWITCH.Managed.dll and that definitely
had an effect. but now when I attempt to > load mod_managed

FreeSwitch core dumps now.


I have tried mono 2.2 and mono 2.0.1


I am running . CentOS 5.2 x86 32bit


[root at sipcore-alpha conf]# uname -a

Linux sipcore-alpha 2.6.18-92.el5 #1 SMP Tue Jun 10 18:49:47 EDT 2008 i686
athlon i386 GNU/Linux


I attached the full output from the console in the txt doc attached above.


I'm wondering if the problem is specific to this flavor of linux. perhaps
more specifically the kernel.




From: freeswitch-users-bounces at lists.freeswitch.org
[mailto:freeswitch-users-bounces at lists.freeswitch.org] On Behalf Of Michael
Sent: Thursday, January 15, 2009 12:34 AM
To: freeswitch-users at lists.freeswitch.org
Subject: Re: [Freeswitch-users] Using mod_managed Linux/Mono 2.02


The managed assembly should be the same on both platforms. The correct name
is FreeSWITCH.Managed.dll. I'll get a patch to the


Meanwhile, simply renaming mod_managed_lib.dll should work.


After that, make sure there's a "managed" subdirectory where the modules





From: freeswitch-users-bounces at lists.freeswitch.org
[mailto:freeswitch-users-bounces at lists.freeswitch.org] On Behalf Of Adam
Sent: Wednesday, January 14, 2009 3:45 PM
To: freeswitch-users at lists.freeswitch.org
Subject: [Freeswitch-users] Using mod_managed Linux/Mono 2.02


Has anyone had any luck using mod_managed under linux with mono yet?

The Wiki looks to still be lacking some linux installation instructions.

I feel like I'm close but missing something simple.


I got as far as adding "languages/mod_managed" to the
/usr/src/freeswitch-1.0.2/modules.conf without quotes obviously.


My installed mono version is

[root at sipcore-alpha mod]# mono -V

Mono JIT compiler version 2.2 (tarball Wed Jan 14 09:44:57 PST 2009)

Copyright (C) 2002-2008 Novell, Inc and Contributors. www.mono-project.com

        TLS:           __thread

        GC:            Included Boehm (with typed GC)

        SIGSEGV:       altstack

        Notifications: epoll

        Architecture:  x86

        Disabled:      none


I can successful compile freeswitch and it indeed compiles mod_managed.so


I added   <load module="mod_managed" />

to my  /usr/local/freeswitch/conf/autoload_configs/modules.conf.xml


I did also create the /usr/local/freeswitch/mod/managed  directory as stated
in the wiki as requirement.


But when I start freeswitch I get the following in regards to the
mod_managed loading.


2009-01-14 14:19:12 [INFO] mod_managed.cpp:309 mod_managed_load() Loading
mod_managed (Common Language Infrastructure), Mono Version

2009-01-14 14:19:12 [INFO] mod_managed.cpp:213 loadRuntime() Calling

2009-01-14 14:19:12 [INFO] mod_managed.cpp:217 loadRuntime() Calling

2009-01-14 14:19:12 [ERR] mod_managed.cpp:220 loadRuntime()
mono_domain_assembly_open failed.

2009-01-14 14:19:12 [CRIT] switch_loadable_module.c:839
switch_loadable_module_load_file() Error Loading module

**Module load routine returned an error**


One thing I think I may be missing is a FreeSWITCH.Managed.dll   (this
exists on windows environment but doesn't seem to be compiled under linux)

I thought perhaps mod_managed_lib.dll was the linux equivalent but that
exists and still no a no go.


Any ideas would be very welcome?  Thank you!










-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20090115/e2bc8cc6/attachment-0002.html 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: freeswitch_loadmanaged.txt
Url: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20090115/e2bc8cc6/attachment-0002.txt 

More information about the FreeSWITCH-users mailing list