[Freeswitch-users] dkpg-buildpackage problem with some modules in debian lenny

Alfonso Pinto elhodred at gmail.com
Fri Apr 24 02:30:13 PDT 2009

Hi guys,

I've builded freeswitch 1.0.3 in some machines with dpkg-buildpackage
without problem, but in a recent install, I've tried to build some
extra mods: mod_lcr, mod_easyroute, mod_python and mod_nibblebill.
To do this I've changed the file debian/rules:

- In export APPLICATIONS_MODULES I've added: applications/mod_lcr
applications/mod_easyroute applications/mod_nibblebill
- In export LANGUAGES_MODULES I've added: languages/mod_python
- In export DISABLED_MODULES I've deleted: languages/mod_python
- I've moved mod_nibblebill directory to src/mod/applications

After that, I've executed dpkg-buildpackage. Then I've installed the
.deb packages.

Now, if I search this modules in /opt/freeswitch/mod, I don't find
them. Instead, if search in the source, I see this modules builded.
I've tried to copy this modules to /opt/freeswitch/mod and have tried
to load them. I got: invalid ELF header on all of them.

Instead, I've tried to build freeswitch with this modules using:
./configure && make && make install, and this modules are installed
and loaded without problems.

Am I doing something wrong with dpkg-buildpackage? Or is this a bug
when building with this tool?


More information about the FreeSWITCH-users mailing list