[Freeswitch-dev] Problem with event_socket application when serving as a consultative transfer target

Mardy Marshall mardy at voysys.com
Wed Jan 20 15:14:48 PST 2010

I'm having a problem with an event_socket application which is the transfer target of a consultative transfer.  When the transferor begins the transfer process, the outbound event_socket session is created and everything looks normal.  When the transfer is completed, switch_ivr_bridge fires a CHANNEL_EXECUTE / "uuid_bridge" event, supplying a new UUID for the "Other-Leg" which corresponds to the transferee.  From this point on, I no longer receive events specific to this new UUID, such as DTMF events or CHANNEL_EXECUTE_COMPLETE events after issuing "playback" commands.  Regarding the "playback" command, if I direct the command to the "Other-Leg" UUID, I get audio, but no events when it is done.  On the other hand, if I direct the command to the original UUID, the one corresponding to the transferrer call leg, I get no audio, but do get completion events.  I have tried re-issuing a "myevents" command using the new UUID, but the command fails due to it only being allowed to be called once per session.

Am I missing something in order to handle the transfer or have I run into a bug?



More information about the FreeSWITCH-dev mailing list