[Freeswitch-dev] FW: Visual Studio 2008 Pro SP1: switch_loadable_module.c:871 Error Loading module .... **dll sym error [127l]

Alex To tonhudung at gmail.com
Sun Nov 1 03:44:26 PST 2009

Sorry, I figured it out by myself. It was because my code file is
mod_mymodule.cpp. I changed it to mod_mymodule.c and the module loaded file.
So I take it as FS accepts only C library but not C++ ?




Alex To


From: Alex To [mailto:tonhudung at gmail.com] 
Sent: Sunday, November 01, 2009 7:35 PM
To: 'freeswitch-dev at lists.freeswitch.org'
Subject: Visual Studio 2008 Pro SP1: switch_loadable_module.c:871 Error
Loading module .... **dll sym error [127l]


Hi, excuse me if this is already asked where else but I did browse through
the mailing list and I couldn't find anything related. I tried to create a
new end point module by copying the mod_skel to mod/endpoints/my_module


I modified "skel" to my module name and basically I leave no codes in the
load function, just a few lines to test if the new module is working. These
few lines are:


*module_interface = switch_loadable_module_create_module_interface(pool,

      modem_endpoint_interface =

      modem_endpoint_interface->interface_name = "modem";

      switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_NOTICE, "Hello




      SWITCH_ADD_API(api_interface, "modem", "Modem API", modem_function,


      /* indicate that the module should continue to be loaded */



It compiles but the module can't load properly. I received the following


2009-11-01 19:18:10.551180 [CRIT] switch_loadable_module.c:871 Error Loading
module D:\Projects\freeswitch\Debug\mod\mod_mymodule.dll

**dll sym error [127l]


I tried to load module normally at the FS console but "load mod_skel" and
"load mod_mymodule" gives the same error.


Would someone tell me what do I miss here. 


Btw, I looked at mod_sofia and mod_iax, this line of code could compile in
those 2 modules.


modem_endpoint_interface =


The same line of code couldn't compile in my module coz VS complains: cannot
convert from void* to switch_endpoint_interface_t*. I know C++ require more
type-safe conversion than C but anyone got the same error?


And how would I search in the mailing list ? Sorry for this dumb question
but I can't seem to find out how to search in the archives. For now, before
posting anything, I need to try to browse through all the postings first,
which is 


quite tedious to do.




Alex To

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-dev/attachments/20091101/c9796390/attachment.html 

More information about the FreeSWITCH-dev mailing list