[Freeswitch-users] rtp-timeout-sec VS media_timeout

Allan Kristensen ak at hejdu.dk
Wed Jan 6 18:37:33 UTC 2021

We had some problems with "hanging channels" for our webrtc clients (via
To solve the problem I tried to use "media_timeout" setting but it didn't
really work. So I tried the deprecated "rtp-timeout-sec" and this actually
works fine?

Not working:
<param name="media_timeout" value="300"/>

<param name="rtp-timeout-sec" value="300"/>

How to reproduce: Make a call using webrtc and just close browser window,
after some time freeswitch should close the channel because of missing rtp.
Instead it just keeps writing: "switch_rtp.c:853 No audio stun for a long
time!" forever...

Anyway, it works now....just curious why...a typo or bug?


FreeSWITCH Version 1.10.5-release+git~20200818T185121Z~25569c1631~64bit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20210106/b75342ee/attachment.html>

More information about the FreeSWITCH-users mailing list