[Freeswitch-users] Timing issues with Verto, SIP client works fine

Support from NetworkedAudio LLC support at naud.io
Thu Jun 18 20:42:28 UTC 2020

Windows Server 2016.
From: FreeSWITCH-users <freeswitch-users-bounces at lists.freeswitch.org> on behalf of Gregor Nanger <gregor at infomedia.si>
Sent: Thursday, June 18, 2020 12:22 PM
To: FreeSWITCH Users Help
Subject: Re: [Freeswitch-users] Timing issues with Verto, SIP client works fine

On which OS is FS installed?

On Thu, 18 Jun 2020, 18:59 Support from NetworkedAudio LLC, <support at naud.io<mailto:support at naud.io>> wrote:
Have done some more testing - the issue appears to be that packets are dropped or a timing resync happens when connecting to PortAudio through the dialplan.


Soft phone (MicroSIP) > Conference > Verto (on Chrome) - sounds great.
Verto (on Chrome) > Conference > Verto (on Chrome) - sounds good, some crunchiness, some drops.
Soft phone (MicroSIP) > PortAudio > external system > PortAudio > Verto (on Chrome) sounds pretty good.
Verto (on Chrome) > PortAudio > external system > PortAudio > Verto (on Chrome) sounds quite poor, lost words.

External system is 48KHz and PortAudio > external system > PortAudio sounds perfect.

Recordings of the above are at https://bit.ly/3EFFyb0

Jitter buffers aren't making any difference and the timer_test shows good numbers. All are using the Opus CODEC.

Any other ideas, please ?

From: Support from NetworkedAudio LLC
Sent: Wednesday, June 10, 2020 2:35 PM
To: FreeSWITCH Users Help <freeswitch-users at lists.freeswitch.org<mailto:freeswitch-users at lists.freeswitch.org>>
Subject: Timing issues with Verto, SIP client works fine

Hi all,

We're using VERTO in an intranet application.

If we do anything other than an echo test, we get dropouts on bridge (to SIP phone or PortAudio), which either drops whole sounds (count 1,2,4,5,7,8) or slurs ("se-even").

This happens with MS Edge (worse) and Chrome (better), with PCMU and OPUS.

Turning off audio processing (googEcho...) has no effect. Changing RTP_TIMER from SOFT to NONE seems to make the dropout more random. It's not a network bandwidth issue - this can happen across a gigabit link.

Using exactly the same computers and headsets but using MicroSIP, everything is perfect.

Have tried jitterbuffers, but they don't help (as it's not a delay issue) - it really feels like a timing problem going from Verto into the rest of the system.

Where should I look now? Have tried 1.10 but no change.

The FreeSWITCH project is sponsored by SignalWire https://signalwire.com
Enhance your FreeSWITCH install with disruptive priced SMS and PSTN services.
Build your next product on our scalable cloud platform.

Join our online community to chat in real time https://signalwire.community

Professional FreeSWITCH Services
sales at freeswitch.com<mailto:sales at freeswitch.com>

Official FreeSWITCH Sites

FreeSWITCH-users mailing list
FreeSWITCH-users at lists.freeswitch.org<mailto:FreeSWITCH-users at lists.freeswitch.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20200618/31d22a4f/attachment.html>

More information about the FreeSWITCH-users mailing list