[Freeswitch-users] mod_portaudio: pa devlist returns ERR unless FS running under root

Tom Lynn tom at tomlynn.com
Tue Jan 28 00:56:13 UTC 2020

I'm having some trouble understanding why the CLI pa command "pa devlist"
returns ERR unless I'm running it under root.  I installed on an ARM single
board computer over the weekend from the ARM repository following the
instructions for raspberry pi.
I can use aplay from the command line to play the music on hold wav files
included with FS.  I've plugged in a USB sound card device and made it the
default sound device and rebooted.  Same result.
The OS image is dietpi and there's no other running processes running that
use sound.  I saw alsactl running and killed it, restarted FS service, but
still no devlist.
Looking back through emails here in the list, there seem to be similar
questions over the years, but with no solve that I found.  Does anybody
have first hand experience with this?  I'm away from home, but I can follow
this up with some console output it if helps.
I'm trying to set up a loudspeaker paging device.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20200127/3d2c673b/attachment.html>

More information about the FreeSWITCH-users mailing list