[Freeswitch-users] Build Problem in VS2015

Adrian Worutowicz adrian.worutowicz at esifrance.net
Mon Jun 19 12:52:31 UTC 2017

I asked a friend of mine to compile and it worked fine.

So it is either a pb of my VS2015 install or a question of Win7 32/64 bit (I have the 32bit version).




De : FreeSWITCH-users [mailto:freeswitch-users-bounces at lists.freeswitch.org] De la part de gregor at infomedia.si -- Gregor Nanger
Envoyé : vendredi 16 juin 2017 21:19
À : FreeSWITCH Users Help
Objet : Re: [Freeswitch-users] Build Problem in VS2015


I do not have problems compiling with visual Studio. Except for cloning, I use same command as stated in wiki. Then open in visual Studio and Build solution. 


On Fri, Jun 16, 2017, 19:39 Adrian Worutowicz <adrian.worutowicz at esifrance.net> wrote:

I followed your steps, but unfortunately I got the same result.

Probably I’m missing something in my VS install.


Thanks a lot anyway…




De : FreeSWITCH-users [mailto:freeswitch-users-bounces at lists.freeswitch.org] De la part de krice at tollfreegateway.com
Envoyé : jeudi 15 juin 2017 18:29
À : 'FreeSWITCH Users Help'
Objet : Re: [Freeswitch-users] Build Problem in VS2015


Not sure whats you are doing incorrect here, but I have just built master, I use the built in git bits with VS2015, and then drop to a command prompt (via the team explorer tab, select branches, right click the repo and select open command prompt)


Then git pull, git clean -fdx, git reset –hard origin/master , git pull


>From here back to the solution explorer open the FreeSWITCH.2015 solution file and build as normal…


I think you have something skewed there old ssl vs new ssl bits 


From: FreeSWITCH-users [mailto:freeswitch-users-bounces at lists.freeswitch.org] On Behalf Of Adrian Worutowicz
Sent: Thursday, June 15, 2017 4:44 AM
To: freeswitch-users at lists.freeswitch.org
Subject: [Freeswitch-users] Build Problem in VS2015




I try to recompile FS in VS2015 without success.

I took FS sources from git master.


git config --global core.autocrlf false

git clone https://stash.freeswitch.org/scm/fs/freeswitch.git /c/ESI/Components/FreeSwitch/ <https://stash.freeswitch.org/scm/fs/freeswitch.git%20/c/ESI/Components/FreeSwitch/> 


I have wix311 for VS2015 installed.


For example it searches in folder 'openssl-1.0.2k' while only a folder 'openssl' exists.


I tried to recompile mod_PortAudio, and I got c:\ESI\components\freeswitch\src\mod\endpoints\mod_portaudio\pablio.h(55): fatal error C1083: Impossible d'ouvrir le fichier include : 'portaudio.h' : No such file or directory.


Indeed 'portaudio.h' does not exist.

Plenty of other errors in the attached file.


What do I miss?


Thanks in advance,


Professional FreeSWITCH Consulting Services:
consulting at freeswitch.org

Official FreeSWITCH Sites

FreeSWITCH-users mailing list
FreeSWITCH-users at lists.freeswitch.org


Gregor Nanger


t./f.: 00386 (0) 7 6000 308/309 • m:. 00386 (0)41 756485 
• Infomedia d.o.o. • Jerebova 3, Novo mesto, Slovenia 
• www.infomedia.si <http://www.infomedia.si/> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20170619/ae7b7486/attachment.html>

More information about the FreeSWITCH-users mailing list