[Freeswitch-users] Cannot compile mod_cepstral

Paul Seethaler seethap at web.de
Wed Oct 15 10:02:35 MSD 2014

Hello All,

I am trying to compile mod_ceptral following the instructions from
it recommends to use 4.x instead of 5 of cesptral, but I can only
download version 6.  As there are some notes
further down for version 6 under ubuntu, I thought I give that a try,

After I disabled flit and enabled cepstral in the modules.conf , I tried
to 'make' freeswich.
But the proccess stumbles over the cepstral compilation with the
following error:

making all mod_cepstral
make[5]: Entering directory
  CC       mod_cepstral_la-mod_cepstral.lo
  CCLD     mod_cepstral.la
/usr/bin/ld: skipping incompatible /opt/swift/lib/libswift.so when
searching for -lswift
/usr/bin/ld: cannot find -lswift
collect2: error: ld returned 1 exit status
make[5]: *** [mod_cepstral.la] Error 1
make[5]: Leaving directory

I have tried various things now.  I have reinstalled freeswtich
completely following the instructions from
the "stable" 1.4 version of freeswitch.  But it is always the same error.

I cannot find a place in the sources where the condition resides that
makes it skip the
/opt/swift/lib/libswift.so  (which does exist, and as far as I can see
is setup correclty via ldconfig)

Anybody have an Ideas?

Kind regards

I am using a virtual box running Ubuntu 14.04 64bit
Freeswitch 1.4stable

Join us at ClueCon 2016 Aug 8-12, 2016
More information about the FreeSWITCH-users mailing list