[Freeswitch-users] mod_conf : play tmp/uuid.wav!userleft on member exit.

Stephen Dame sdame at 207me.com
Fri Aug 8 23:55:40 MSD 2014

I’ve successfully been able to modify dialplan to prompt caller for name, record it and announce in conference per wiki. solution works great. Adding a few lines of code makes sure they can only enter existing conferences.


Now that I have their name in temp wav file, trying to decide best approach to play  name!” is leaving conference” into conference when they leave.


Before heading down a path. Wanted to seek some advice on some possible approaches.


1)      Thought I may be able to set exit  sound in conf profile with UUID but not sure variables are expanded at run time.


2)      The other approach is to monitor ESL conference events and play back the UUID file when its detected that they have left (separate process)


3)      Modify source of mod_conf to hardcode playing of /tmp/uuid when member leaves only if the file exists.


Is there an easier way I’m missing?





From: freeswitch-users-bounces at lists.freeswitch.org [mailto:freeswitch-users-bounces at lists.freeswitch.org] On Behalf Of Anthony Minessale
Sent: Friday, August 08, 2014 12:17 PM
To: Freeswitch-users
Subject: Re: [Freeswitch-users] No audio with WebRTC, cannot find certs


Try deleting all the files with dtls in the name and restart to let it regenerate.   Also try master rev.

On Aug 8, 2014 11:13 AM, "A.B. Carroll" <ben at hl9.net <mailto:ben at hl9.net> > wrote:



I'm experiencing similar issues as stated here:



Running FreeSWITCH Version 1.4.7-1~64bit (-1 64bit), Debian Wheezy using the official repos


With the following errors:

2014-08-08 15:32:33.116140 [ERR] switch_core_cert.c:210 FP FILE ERR!


2014-08-08 15:32:33.136126 [ERR] switch_rtp.c:2974 audio DTLS cert err [5]


I'm really lost here, .. I've tried using the -certs parameter, as per reading the source, and mentioned in the

above post.  Stock, the directory: /etc/freeswitch/tls/ existed with a file dtls-srtp.pem that is a pub+priv key

combined.  I tried specifying that directory with the '-certs' argv as well as copying the .pem to .crt, and even

having all four files:





.. exist, with mode +rw all (including the directories themselves)


And no luck, same error, it seems Freeswitch just refuses to see the file, unlike the mailing list post I'm referencing.


Can anyone offer some advice?  P.S. I am using the freeswitch and sipML5 examples -- they work fine with the freeswitch server, so I'm assuming this is the issue.



A.B. Carroll

Professional FreeSWITCH Consulting Services:
consulting at freeswitch.org <mailto:consulting at freeswitch.org> 

Official FreeSWITCH Sites

FreeSWITCH-users mailing list
FreeSWITCH-users at lists.freeswitch.org <mailto:FreeSWITCH-users at lists.freeswitch.org> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20140808/0069b0a1/attachment.html 

Join us at ClueCon 2016 Aug 8-12, 2016
More information about the FreeSWITCH-users mailing list