[Freeswitch-users] No audio with WebRTC, cannot find certs

A.B. Carroll ben at hl9.net
Fri Aug 8 19:53:40 MSD 2014


I'm experiencing similar issues as stated here:

Running FreeSWITCH Version 1.4.7-1~64bit (-1 64bit), Debian Wheezy using
the official repos

With the following errors:
2014-08-08 15:32:33.116140 [ERR] switch_core_cert.c:210 FP FILE ERR!
2014-08-08 15:32:33.136126 [ERR] switch_rtp.c:2974 audio DTLS cert err [5]

I'm really lost here, .. I've tried using the -certs parameter, as per
reading the source, and mentioned in the
above post.  Stock, the directory: /etc/freeswitch/tls/ existed with a file
dtls-srtp.pem that is a pub+priv key
combined.  I tried specifying that directory with the '-certs' argv as well
as copying the .pem to .crt, and even
having all four files:
.. exist, with mode +rw all (including the directories themselves)

And no luck, same error, it seems Freeswitch just refuses to see the file,
unlike the mailing list post I'm referencing.

Can anyone offer some advice?  P.S. I am using the freeswitch and sipML5
examples -- they work fine with the freeswitch server, so I'm assuming this
is the issue.

A.B. Carroll
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20140808/afb06547/attachment.html 

Join us at ClueCon 2016 Aug 8-12, 2016
More information about the FreeSWITCH-users mailing list