[Freeswitch-users] Calls from api originate disconnect after 5 minutes

Fraser Redmond fraserredmond at gmail.com
Sat Jul 20 16:15:01 MSD 2013

Some of our calls are getting disconnected after exactly 5 minutes. I've
finally narrowed it down to be something to do with how the calls are
initiated. We have 2 ways of initiating calls:

1) Direct from a softphone out to a gateway to a landline number - this
doesn't disconnect after 5min

2) From our webapp using php and fsock to call a command like this:
    api originate
(I pass through about 8-10 vars. I've tried removing them all, but it still
The call works fine and everything is normal until 5 minutes after the call
was answered, at which point it hangs up (usually with a second or two,
sometimes up to 10 seconds after the 5 minute mark.)

A few things I've already tried and ruled out:

- I've stripped out all the javascript files that we run, variables we set,
and commands we run, so that the only part of the dialplan that gets
executed are just:
    <action application="bridge"

- Right before it disconnects there are no extra lines in the sip log
(other than those to handle the hangup.) There's also no sip messages in
the log immediately before it disconnects.

- A year ago I set "record_waste_resources=true" and that seemed to fix it
at the time - but it may have only fixed the calls direct from the

- In the internal and external profiles I've set rtp-timeout-sec=3600 (it
used to be 300, and I thought that might be the cause.)

- I've done a file compare between the log outputs of each type of call and
theres differences that I'd expect because of the different types of call,
but otherwise they're about the same. (Differences in how the codec gets
set, and a slightly different route through the dialplan.)

A few other details about our setup

- I upgrade to the latest version of freeswitch regularly, but the problem
has been happening for months or years.

- Our production server is on Amazon AWS, so there could be a NAT issue...
but it also happens on my dev server on my local network (though that is
behind a NAT too, so it could be the NAT between my dev server and the
gateway... what would I do about that? And why would it happen with one
type of call, but not the other.)

- Normally, all our calls are recorded, so I'm not doing bypass-media. The
wav file for a 5min recording is just slightly under 10mb, so I had been
wondering if that was the limit being hit, but it still disconnects if
recording is off.

- I've tried with a different gateway and different softphone, and it still

- Here's a full log output (with sip) if you want to take a look:

http://pastebin.freeswitch.com/21212 (this is direct from the softphone, in
case the comparison helps)

I'm stumped, so any ideas or advice would be much appreciated. I have a
pcap I can send if you want to look at one.

My best guess right now is that it's a bug to do with api originate. (That
it's setting a variable that a normal call doesn't, or vice-versa.)

Or is there something I should change about the format of either:
(I set up the format of both of those strings about 3 years ago, so maybe
there's a better way to do it now.)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20130720/64cf2612/attachment.html 

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list