[Freeswitch-users] Build errors in 2010.express solution

FSX ml88888 at hotmail.com
Wed Apr 10 10:51:07 MSD 2013

What exactly do you mean "fresh clone"?

Last time I build this solution without any problems was two weeks ago.
Yesterday I did "Clean Solution" and build.Got a lot of fatal errors. I
applied "Rebuild Solution", got the same result. Today I've pulled latest
git "c9a49b0", I've removed solution files and pulled them from git
repository back, I've run "git status" to make sure that I have latest and
correct sources. I've repeated "Clean Solution" again and build it twice to
get this bottom line:
========== Build: 21 succeeded, 72 failed, 53 up-to-date, 18 skipped

The only thing I do with solution properties configuration is I turn off
project "mod_managed", Debug_CLR configuration, Win32 platform, because I
always getting errors building it. The rest is default. And, as I said, I
build it successfully for years. But now (actually a week ago or so)
something becomes suddenly wrong and I'm getting lot of fatal errors... 

The first fatal error is this:
LINK : fatal error LNK1181: cannot open input file

It's because when VS tried to make FreeSwitchCoreLib, it failed:
------ Build started: Project: FreeSwitchCoreLib, Configuration: Debug Win32
  Generating switch_version.inc
  Checking if we're building a newer git version
..\..\src\switch_rtp.c(2270): error C2220: warning treated as error - no
'object' file generated
..\..\src\switch_rtp.c(2270): warning C4013: 'SSL_CTX_set_tlsext_use_srtp'
undefined; assuming extern returning int
------ Build started: Project: iksemel, Configuration: Debug Win32 ------

View this message in context: http://freeswitch-users.2379917.n2.nabble.com/Build-errors-in-2010-express-solution-tp7589476p7589585.html
Sent from the freeswitch-users mailing list archive at Nabble.com.

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list