[Freeswitch-users] FreeSWITCH-users Digest, Vol 72, Issue 66

BELint Inc belintinc at gmail.com
Sat Jun 9 18:57:51 MSD 2012

 Thanks Dave,

We already tried "NDLB-connectile-dysfunction=true" as the client (Yealink
T28P) is not using rport in its VIA header. But still no luck freeswitch
still sending the response to the port in Contact header (5062) instead of
the recieving port (14335). 5062 port is actually not valid as the client
is behind NAT and only can get the response if freeswitch will send it to
14335 port.

Do you have any other idea about this?
:-( .........


> ---------- Forwarded message ----------
> From: "Dave R. Kompel" <drk at drkngs.net>
> To: "FreeSWITCH Users Help" <freeswitch-users at lists.freeswitch.org>
> Cc:
> Date: Thu, 07 Jun 2012 21:35:56 -0700
> Subject: Re: [Freeswitch-users] Freeswitch is responding to contact's port
> when client behind NAT
> **
> Sorry for the long delay, but here's your answer:
> It's going to go to the address in the un-altered VIA header, unless RPORT
> gets sent it the VIA. If you have agressive_nat_detection turned on, and
> the client puts RPORT in the via, it will work fine. If you have a broken
> device that won't do it, then set the variable
> "NDLB-connectile-dysfunction=true" in the users directory enter (XML) or
> other, what ever you are using. That will cause the contact to be
> re-written to the transport address from where it came (both ip address and
> port) and the response will also be sent there.
> --Dave
>  ------------------------------
> *From:* BELint Inc [mailto:belintinc at gmail.com]
> *To:* freeswitch-users at lists.freeswitch.org
> *Sent:* Thu, 07 Jun 2012 10:56:07 -0700
> *Subject:* Re: [Freeswitch-users] Freeswitch is responding to contact's
> port when client behind NAT
> Does any one know its solutions,
> Guys please help, its urgent. I am even unable to register my phones :-(
> Regards,
> On Thu, Jun 7, 2012 at 9:20 AM, BELint Inc <belintinc at gmail.com> wrote:
>> Hi All,
>> We`ve been using freeswitch since very long, It was good all over but it
>> got stuck to a simple yet complex situation. We have Yealink T28P series
>> phones behind NAT and freeswitch is unable to get them register. In the
>> scenario freeswitch is at public IP. The reason we think is that freeswitch
>> is using sip port in contact header to respond to.
>> Is there anyway we can avoid this or force it to always send the response
>> to destination IP instead of contact or via header ports because clients
>> are behind NAT and response can only reach them if it respond to
>> destination IP & PORT.
>> Please revert if someone know how to solve this problem. It is very
>> urgent.
>> Regards
>> BELint
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20120609/6524665e/attachment-0001.html 

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list