[Freeswitch-users] mod_portaudio cannot find input or output device

Brett Wilson brett at launch3.net
Fri Aug 17 21:17:52 MSD 2012

I disabled loading of any modules besides the bare miniumum, still no dice.
I set the in/out device as #0 as shown with aplay -l. Still no good.

Brett Wilson
IT Department
Launch 3 Ventures, LLC 
134 Myer Street 
Hackensack, NJ 07601 
Phone: 877.878.9134
Fax: 646.536.3866 
Email: Brett.Wilson at launch3.net
AOL IM: Brett.Wilson at launch3.net

-----Original Message-----
From: Patrick Lists [mailto:freeswitch-list at puzzled.xs4all.nl] 
Sent: Friday, August 17, 2012 8:45 AM
To: freeswitch-users at lists.freeswitch.org
Subject: Re: [Freeswitch-users] mod_portaudio cannot find input or output

On 17-08-12 14:18, Brett Wilson wrote:
> *freeswitch at internal> load mod_portaudio*
> +OK Reloading XML
> -ERR [module load file routine returned an error]

That ERR does not look good. Iirc I have seen that with mod_java when
starting FreeSWITCH. Subsequent manual loading of the mod_java module went
fine. But in your case you are already manually loading the module.

> *2012-08-17 08:15:23.591770 [ERR] mod_portaudio.c:1767 Cannot find an 
> input device*
> *2012-08-17 08:15:23.591770 [ERR] mod_portaudio.c:1777 Cannot find an 
> output device*

Did you set the input/output devices? Lot's of info on the wiki:



Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list