[Freeswitch-users] Using Softphone on same machine as FreeSwitch?

LearningFS amilkhanzada at gmail.com
Mon Apr 9 00:18:51 MSD 2012

Hi guys,

I am on Ubuntu 10.04 inside a VirtualBox virtual machine (my host OS is
Windows 7).
I am running FreeSwitch on Ubuntu.

However, when I try to connect with any softphone within my Ubuntu, it
cannot connect to FreeSwitch and FS does not receive the connection requests
on command prompt.
I tried connecting to port 5060 on the "inet addr:" shown in ifconfig. I
double-checked the ports in my FS conf directory.

I don't think it will work for me to use the public IP address of my Ubuntu
because this is all hidden behind my virtual machine NAT + my router +
symantec and windows firewall on my Windows machine. I tried doing a bunch
of port forwarding stuff, but this did not work out very well...

Is there any way to connect a softphone to FS internally within Ubuntu?

Also, I want to test out mod_sms. I think qutecom is suitable for this

Thanks and sorry if this was answered before. I tried searching for it.
View this message in context: http://old.nabble.com/Using-Softphone-on-same-machine-as-FreeSwitch--tp33649239p33649239.html
Sent from the Freeswitch-users mailing list archive at Nabble.com.

Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list