[Freeswitch-users] Missing Events in mod_event_socket

Gerry Hull gerry at pstn2.net
Thu May 28 14:20:46 PDT 2009


I am a Windows developer who has written an application around the
event_socket interface.  My client piece started with the C# EventSocket
client Jonas Gauffin had posted on CodePlex.
Well, Jonas did not keep up that code on Codeplex, but after communicating
with him, I did get the latest client-side code from the freeaswitch SVN,
and it seems to work fine.

However, their is a persistent, nasty bug I'm seeing:

On an inbound call to FreeSwitch, I get the EventChannelAnswer event, which
gives me some of the info I need on the incoming call.
Following that event, I should get an EventChannelExecuteComplete event,
which gives me important information like call-direction,
channel-state, answer-state, caller-destination-number,
caller-caller-id-name, etc.

The problem I'm seeing is that EventChannelAnswer ALWAYS fires on an inbound
call, but EventChannelExecuteComplete does not fire --randomly.   I thought
this mighrt have something to do with linger,
but executing the linger command does not help.

Jonas made the following comment on the issue:

"It has been a bug in the eventsocket implementation in freeswitch.   It can
sometimes skip packets if the socket layer in the os gives an  error code
(internal socket buffer becomes full).
A simple send retry usually fixes the problem. I've created a patch for it
long time ago (and reported it in FS jira). Mike Jerris have made an own fix
for the issue. I do not know if it works, I'm still
running my own patch.  I've attached it to this email. It's a patch for
freeswitch\src\mod\event_handlers\mod_event_socket\  mod_event_socket.c,
everything works gr8 for me with it."

Well, I have no idea how to apply the patch.

I've downloaded the latest code from trunk at files.freeswitch.org, and
built FS using Visual Studio 2008.   all compiles fine.    However, the bug
sticks it's nasty head up randomly about every other call.

I've never done a patch... I tried downloading GNU Patch for windows, and
tried applying it, but it reported errors.

Has this issue been fixed in core code?  If not, can someone help me patch
this?  I'm dead in the water on a project until I resolve this.   In every
other aspect, I've found FS to be flawless.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20090528/6d4c74a6/attachment-0002.html 

More information about the FreeSWITCH-users mailing list