[Freeswitch-users] Gateway issue with no audio

Henry Huang b_ball_henry at hotmail.com
Thu Dec 3 01:36:46 PST 2009

My freeswitch is using public IP. I setup a gateway registering to
voipstunt, and put it under internal profile. I tried to make call, and I
got no RTP back from the provider... Tried treating NAT issue by changing IP
address, internal IP, external IP. But no use, still getting no audio.

Finally, I gave up play around with the internal profile and put the gateway
*settings under external profile. And magically, it worked.* I am getting
audio now. But it leads me to wonders, what's the core difference between
external profile and internal profile. Even if I set the external SIP IP and
exteranl RTP IP to the public IP in internal profile, I am still getting no
audio. Can anyone clear the concept for me here?

by the way, I am using freeswitch 1.4 stable version.

Henry Huang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20091203/8d14e1f8/attachment-0002.html 

More information about the FreeSWITCH-users mailing list