[Freeswitch-users] Not receiving DTMF

Nicolas Brenner nicolas at medularis.com
Sat Aug 15 18:28:15 PDT 2009

Hi, I'm trying to get dtmf input, but I'm not getting anything.

What I discovered though, is that my provider is at fault, since when I
switched to another voip provider, everything started to work beautifully.

My question is: since my provider is not doing RC2833 dtmf (even though they
say they do), is there another way to get dtmf to work? I'm doing everything
in a javascript file, so I tried doing:

- session.setVariable("dtmf_type","info");


- session.setVariable("dtmf_type","rfc2833");


- session.execute("start_dtmf");

But none worked. The voip provider that works would be ideal, but the calls
are twice as expensive, hence besides testing, I wouldn't use them for a
real case scenario. BTW, anyone know of a good quality VoIP provider with
low rates for termination to Santiago, Chile and Chilean cell phones?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20090815/b32d4b0d/attachment-0002.html 

More information about the FreeSWITCH-users mailing list