[Freeswitch-users] latest freeswitch for windows doesnt run using TLS

Brian West brian at freeswitch.org
Wed Aug 20 07:16:19 PDT 2008

On Aug 20, 2008, at 7:44 AM, xbipin wrote:

> hi,
> i failed to run the latest freeswitch msi package using TLS on port  
> 5061 on
> windows xp, i have reported this multiple times but havent got any  
> positive
> feedback from others as well as no solution to the bug.

Have you reported this to jira.freeswitch.org?  This is the first I  
have heard of this.

> the bug is, under windows xp when u install and the run freeswitch,  
> it works
> fine in standard sip mode but as soon as u turn the tls function to  
> true and
> then re run it, sofia gives a thread error i think error number is  
> 552 or
> something like that, basically what i understand from other posts is  
> that it
> cant listen on port 5061 but i got nothing running on that port at  
> all so
> then whats causing it not to run?

TLS isn't enabled by default on ANY built for one single reason.  You  
have to make your TLS certificates.  And on windows I would bet that  
Sofia isn't compiled with OpenSSL support and thats the reason its not  

> this has been the issue since the first version of freeswitch i have  
> tried
> to the latest one present, i even compiled the source on windows and  
> then
> tried but its the same so just hope that some1 could get a solution  
> for it.
> What others have reported that it run fine on linux using tls but  
> doesnt on
> windows using TLS.

Open a bug on Jira under build system issues.  Its not a bug with the  
code but with the build system on windows.

> Regards,
> Bipin

Brian West
sip:brian at freeswitch.org

More information about the FreeSWITCH-users mailing list