[Freeswitch-users] help getting FXO inbound to bridge to

Ian Henderson ianhe at email.com
Sat Aug 16 20:48:42 PDT 2008

Thanks very much for remembering about my request.  The card was a recent eBay purchase so I was keen to confirm it worked sooner rather than later.

Consequently, I built and installed Asterisk, keeping the Zaptel install unchanged.  I managed to get that working on the inbound FXO with a small "fix", but have yet to try the workaround in FS.  I'm hoping that the fix will translate.

Basically, for testing I am using a Netgear TA612V as the FXS ports that I'm connecting to.  Asterisk was also initially failing, but by debugging through the SIP I noticed that the Caller Id was coming in with 2 lots of double quotes, i.e. ""tav612v line 1"".  It would appear that both the Cisco 7940 and another phone, a Welltech LP201, were rejecting the SIP request due to the double double quotes, with, from memory, a 400 error.  I probably didn't have enough debugging configured in FS to see this issue.

I tried overriding the callerid in Asterisk, and the SIP request was successful and the call connected.  As I said, I haven't had the chance to reconfigure back to FS and apply the same fix.  Happy to update the list when I do and confirm, or seek further guidance.

Thanks again for getting back to me,

> Ian,
> My apologies for not following up sooner.  Where you able to get past this
> issue?  I just got my hands on a NxtVox TDM400 compatible card so I will
> hopefully be playing with it soon.  I'm sure that what you are trying to do
> is not at all unusual and should be easily accomplished with the correct
> setup.  I will work to get that setup properly documented.

Be Yourself @ mail.com!
Choose From 200+ Email Addresses
Get a Free Account at www.mail.com

More information about the FreeSWITCH-users mailing list