I need to generate calls with Invite URIs in this format: INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0 Is there an easy way to do this? Thanks.
Params are not added before the @ sign that I'm pretty sure of. <action application="export" data="sip_invite_params=this=kewl;that=iskewl"/> <action application="bridge" data="sofia/profile/blah@blah"/> Results in INVITE sip:blah@blah;this=kewl;that=iskewl SIP/2.0 You also have sip_invite_to_params, sip_invite_from_params, sip_invite_contact_params /b On Mar 27, 2009, at 5:11 AM, James H Thompson wrote:
I need to generate calls with Invite URIs in this format:
INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0
Is there an easy way to do this?
Thanks.
Brian West brian@freeswitch.org -- Meet us a ClueCon! http://www.cluecon.com
Some platforms add/use URI params in the user portion of the URI. I was just reminded of this this week with Global Crossing: sip:+18005551212;npdi=yes@0.0.0.0 That is (of course) the number portability display indicator... ;) Anyways, I had to rewrite the URI using OpenSIPS to strip the ";npdi=yes". I imagine you could do the same but I'm not sure how in FreeSWITCH... 2009/3/27 Brian West <brian@freeswitch.org>:
Params are not added before the @ sign that I'm pretty sure of. <action application="export" data="sip_invite_params=this=kewl;that=iskewl"/>
<action application="bridge" data="sofia/profile/blah@blah"/>
Results in INVITE sip:blah@blah;this=kewl;that=iskewl SIP/2.0
You also have sip_invite_to_params, sip_invite_from_params, sip_invite_contact_params /b
On Mar 27, 2009, at 5:11 AM, James H Thompson wrote:
I need to generate calls with Invite URIs in this format:
INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0
Is there an easy way to do this?
Thanks.
-- Kristian Kielhofner http://blog.krisk.org http://www.submityoursip.com http://www.astlinux.org http://www.star2star.com
Thats about dumb... um I don't think we let you put things in there.. but it would only be a few lines to do it...blah rfc's suck! /b On Mar 27, 2009, at 2:47 PM, Kristian Kielhofner wrote:
Some platforms add/use URI params in the user portion of the URI.
I was just reminded of this this week with Global Crossing:
sip:+18005551212;npdi=yes@0.0.0.0
That is (of course) the number portability display indicator... ;)
Anyways, I had to rewrite the URI using OpenSIPS to strip the ";npdi=yes". I imagine you could do the same but I'm not sure how in FreeSWITCH.
Brian West brian@freeswitch.org -- Meet us a ClueCon! http://www.cluecon.com
You seem to be confusing your standards, those 2 specs are about tel: uri's not sip: uris. Sending a tel uri I am not sure we can do, where would we send it to? Mike On Mar 27, 2009, at 6:11 AM, James H Thompson wrote:
I need to generate calls with Invite URIs in this format:
INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0
Is there an easy way to do this?
Thanks.
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
Calls would be sent to the IP address after the '@' in the URI. Section 19.1.1 of RFC 3261 seems to say that TEL URIs can be used as the user part of a SIP URI. My example Invite URI is the way we are receiving traffic from some of the major telecom carriers. We would like be able to generate calls using the same formats. ----- Original Message ----- From: Michael Jerris To: freeswitch-users@lists.freeswitch.org Sent: Friday, March 27, 2009 5:41 AM Subject: Re: [Freeswitch-users] generating RFC 3966 and RFC 4694 calls You seem to be confusing your standards, those 2 specs are about tel: uri's not sip: uris. Sending a tel uri I am not sure we can do, where would we send it to? Mike On Mar 27, 2009, at 6:11 AM, James H Thompson wrote: I need to generate calls with Invite URIs in this format: INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0 Is there an easy way to do this? Thanks. _______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org -------------------------------------------------------------------------------- _______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
if you prefix the sofia dial string with sip: you should be able to pass anything you want. sofia/internal/sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060<rn=9083820000@204.123.123.123:5060> 2009/3/27 James H Thompson <jht@lj.net>
Calls would be sent to the IP address after the '@' <%27@%27> in the URI. Section 19.1.1 of RFC 3261 seems to say that TEL URIs can be used as the user part of a SIP URI. My example Invite URI is the way we are receiving traffic from some of the major telecom carriers. We would like be able to generate calls using the same formats.
----- Original Message ----- *From:* Michael Jerris <mike@jerris.com> *To:* freeswitch-users@lists.freeswitch.org *Sent:* Friday, March 27, 2009 5:41 AM *Subject:* Re: [Freeswitch-users] generating RFC 3966 and RFC 4694 calls
You seem to be confusing your standards, those 2 specs are about tel: uri's not sip: uris. Sending a tel uri I am not sure we can do, where would we send it to? Mike
On Mar 27, 2009, at 6:11 AM, James H Thompson wrote:
I need to generate calls with Invite URIs in this format:
INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060<rn=9083820000@204.123.123.123:5060> SIP/2.0
Is there an easy way to do this?
Thanks.
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
------------------------------
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
-- Anthony Minessale II FreeSWITCH http://www.freeswitch.org/ ClueCon http://www.cluecon.com/ AIM: anthm MSN:anthony_minessale@hotmail.com <MSN%3Aanthony_minessale@hotmail.com> GTALK/JABBER/PAYPAL:anthony.minessale@gmail.com<PAYPAL%3Aanthony.minessale@gmail.com> IRC: irc.freenode.net #freeswitch FreeSWITCH Developer Conference sip:888@conference.freeswitch.org <sip%3A888@conference.freeswitch.org> iax:guest@conference.freeswitch.org/888 googletalk:conf+888@conference.freeswitch.org<googletalk%3Aconf%2B888@conference.freeswitch.org> pstn:213-799-1400
On Mar 28, 2009, at 4:05 AM, Anthony Minessale wrote:
if you prefix the sofia dial string with sip: you should be able to pass anything you want.
sofia/internal/sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060
Is that similar as this? <action application="bridge" data="sofia/sip/9998881111@sip.yourprovider.com "/> got it from wiki: http://wiki.freeswitch.org/wiki/Misc._Dialplan_Tools_bridgecall#From_the_Dia...
2009/3/27 James H Thompson <jht@lj.net> Calls would be sent to the IP address after the '@' in the URI. Section 19.1.1 of RFC 3261 seems to say that TEL URIs can be used as the user part of a SIP URI. My example Invite URI is the way we are receiving traffic from some of the major telecom carriers. We would like be able to generate calls using the same formats.
----- Original Message ----- From: Michael Jerris To: freeswitch-users@lists.freeswitch.org Sent: Friday, March 27, 2009 5:41 AM Subject: Re: [Freeswitch-users] generating RFC 3966 and RFC 4694 calls
You seem to be confusing your standards, those 2 specs are about tel: uri's not sip: uris. Sending a tel uri I am not sure we can do, where would we send it to?
Mike
On Mar 27, 2009, at 6:11 AM, James H Thompson wrote:
I need to generate calls with Invite URIs in this format:
INVITE sip:9085551212;npdi=yes;rn=9083820000@204.123.123.123:5060 SIP/2.0
Is there an easy way to do this?
Thanks.
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
_______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
-- Anthony Minessale II
FreeSWITCH http://www.freeswitch.org/ ClueCon http://www.cluecon.com/
AIM: anthm MSN:anthony_minessale@hotmail.com GTALK/JABBER/PAYPAL:anthony.minessale@gmail.com IRC: irc.freenode.net #freeswitch
FreeSWITCH Developer Conference sip:888@conference.freeswitch.org iax:guest@conference.freeswitch.org/888 googletalk:conf+888@conference.freeswitch.org pstn:213-799-1400 _______________________________________________ Freeswitch-users mailing list Freeswitch-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
no sofia/profile/sip:blah@blah sip: makes sofia take it as is. /b On Mar 27, 2009, at 9:39 PM, dujinfang wrote:
Is that similar as this?
<action application="bridge" data="sofia/sip/9998881111@sip.yourprovider.com "/>
Brian West brian@freeswitch.org -- Meet us a ClueCon! http://www.cluecon.com
participants (6)
-
Anthony Minessale
-
Brian West
-
dujinfang
-
James H Thompson
-
Kristian Kielhofner
-
Michael Jerris