Re- BT SIP Testing require FreeSWITCH main developer's statement of compliance
I guess this is targeted at Anthony, however Brian or Michael may also be able to answer these. I am currently undertaking BT's SIP compliance testing on behalf of my client in the UK (on the latest production release of FreeSWITCH 1.4.20) and BT have requested the following off the software supplier (which could also be in the form of documentation, however if you simply state "Yes" for each of these then that should be enough): 1) RFC 3261 compliance a. I have already pointed BT to https://freeswitch.org/confluence/display/FREESWITCH/Specifications 2) RFC 3550 compliance 3) RTP clock-source accuracy (RTP clock sources shall be accurate to within 66ppm (ie. Shall not drift from a stratum 0 clock source by more than 20ms over the course of a 3 minute call) 4) When calculating the jitter estimate to be sent in a receiver report the variable holding this data shall be initialised to zero before the first incoming RTP packet is processed (i.e. the "s->jitter" variable in RFC 3550 [8] Appendix A.8) 5) RFC 2833 compliance a. I have already pointed BT to https://freeswitch.org/confluence/display/FREESWITCH/Specifications 6) RFC 4028 keep-alive timer compliant 7) Feature support: a. Call-hold reject b. RFC 3264 compliance c. Call-hold black-holing 8) G.711 Packet Loss Concealment (as described in G.711 Appendix I) Like I said above BT are just looking for a statement to say these are supported inside FreeSWITCH from the developers of FreeSWITCH. That is why a simple "yes" will suffice. One idea is to perhaps add all of these (the ones that are missing) to the https://freeswitch.org/confluence/display/FREESWITCH/Specifications page. Just an idea. Thanks in advance, Andrew Keil Visytel Pty Ltd
Have you had a chance to email consulting@freeswitch.org? I've seen a few large organizations require certifications like this, so it might be interesting to look into a two way certification process. At least one of these requirements have to do with the hardware more so than FS itself. William King Senior Engineer Quentus Technologies, INC 1037 NE 65th St Suite 273 Seattle, WA 98115 Main: (877) 211-9337 Office: (206) 388-4772 Cell: (253) 686-5518 william.king@quentustech.com On 8/3/15 7:26 AM, Andrew Keil wrote:
I guess this is targeted at Anthony, however Brian or Michael may also be able to answer these.
I am currently undertaking BT’s SIP compliance testing on behalf of my client in the UK (on the latest production release of FreeSWITCH 1.4.20) and BT have requested the following off the software supplier (which could also be in the form of documentation, however if you simply state “Yes” for each of these then that should be enough):
1) RFC 3261 compliance
a. I have already pointed BT to https://freeswitch.org/confluence/display/FREESWITCH/Specifications
2) RFC 3550 compliance
3) RTP clock-source accuracy (RTP clock sources shall be accurate to within 66ppm (ie. Shall not drift from a stratum 0 clock source by more than 20ms over the course of a 3 minute call)
4) When calculating the jitter estimate to be sent in a receiver report the variable holding this data shall be initialised to zero before the first incoming RTP packet is processed (i.e. the “s->jitter” variable in RFC 3550 [8] Appendix A.8)
5) RFC 2833 compliance
a. I have already pointed BT to https://freeswitch.org/confluence/display/FREESWITCH/Specifications
6) RFC 4028 keep-alive timer compliant
7) Feature support:
a. Call-hold reject
b. RFC 3264 compliance
c. Call-hold black-holing
8) G.711 Packet Loss Concealment (as described in G.711 Appendix I)
Like I said above BT are just looking for a statement to say these are supported inside FreeSWITCH from the developers of FreeSWITCH. That is why a simple “yes” will suffice.
One idea is to perhaps add all of these (the ones that are missing) to the https://freeswitch.org/confluence/display/FREESWITCH/Specifications page. Just an idea.
Thanks in advance,
Andrew Keil
*Visytel Pty Ltd*
_________________________________________________________________________ Professional FreeSWITCH Consulting Services: consulting@freeswitch.org http://www.freeswitchsolutions.com
Official FreeSWITCH Sites http://www.freeswitch.org http://confluence.freeswitch.org http://www.cluecon.com
FreeSWITCH-users mailing list FreeSWITCH-users@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org
participants (2)
-
Andrew Keil
-
William King