I believe the “variable_” prefix only applies to CDRs and logs. When processing them in the dialplan omit the “variable_” prefix and just use
pre_transfer_caller_id_name
Bote
FreeSWITCH Docs Janitor
http://freeswitch.org/confluence
From: freeswitch-users-bounces@lists.freeswitch.org [mailto:freeswitch-users-bounces@lists.freeswitch.org] On Behalf Of Paul Atreides
Sent: Sunday, 15 March, 2015 11:43
To: FreeSWITCH Users Help
Subject: [Freeswitch-users] Channel Variable: variable_pre_transfer_caller_id_number
Hi,
<action application="info"/>
when I call the info app in my dial plan then I can see the following vars in my log
variable_pre_transfer_caller_id_name: []
variable_pre_transfer_caller_id_number: [18]
But when I try to access one single channel variable its always empty. Why?
${variable_pre_transfer_caller_id_number}Thank you for your help.
_________________________________________________________________________
Professional FreeSWITCH Consulting Services:
consulting@freeswitch.org
http://www.freeswitchsolutions.com
Official FreeSWITCH Sites
http://www.freeswitch.org
http://confluence.freeswitch.org
http://www.cluecon.com
FreeSWITCH-users mailing list
FreeSWITCH-users@lists.freeswitch.org
http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
http://www.freeswitch.org