[commit] r6334 - freeswitch/trunk/src/mod/endpoints/mod_sofia
Author: anthm Date: Mon Nov 19 12:09:46 2007 New Revision: 6334 Modified: freeswitch/trunk/src/mod/endpoints/mod_sofia/mod_sofia.c freeswitch/trunk/src/mod/endpoints/mod_sofia/sofia_glue.c Log: omgwtf Modified: freeswitch/trunk/src/mod/endpoints/mod_sofia/mod_sofia.c ============================================================================== --- freeswitch/trunk/src/mod/endpoints/mod_sofia/mod_sofia.c (original) +++ freeswitch/trunk/src/mod/endpoints/mod_sofia/mod_sofia.c Mon Nov 19 12:09:46 2007 @@ -1607,6 +1607,7 @@ switch_set_flag_locked(tech_pvt, TFLAG_OUTBOUND); switch_clear_flag_locked(tech_pvt, TFLAG_LATE_NEGOTIATION); switch_channel_set_state(nchannel, CS_INIT); + tech_pvt->caller_profile = caller_profile; *new_session = nsession; cause = SWITCH_CAUSE_SUCCESS; if (session) { Modified: freeswitch/trunk/src/mod/endpoints/mod_sofia/sofia_glue.c ============================================================================== --- freeswitch/trunk/src/mod/endpoints/mod_sofia/sofia_glue.c (original) +++ freeswitch/trunk/src/mod/endpoints/mod_sofia/sofia_glue.c Mon Nov 19 12:09:46 2007 @@ -629,6 +629,13 @@ from_str = sofia_overcome_sip_uri_weakness(session, use_from_str, NULL); to_str = sofia_overcome_sip_uri_weakness(session, tech_pvt->dest_to, NULL); + /* + Does the "genius" who wanted SIP to be "text-based" so it was "easier to read" even use it now, + or did he just suggest it to make our lives miserable? + */ + use_from_str = from_str; + from_str = switch_core_session_sprintf(session, "\"%s\" <%s>", tech_pvt->caller_profile->caller_id_name, use_from_str); + tech_pvt->nh = nua_handle(tech_pvt->profile->nua, NULL, NUTAG_URL(url_str), SIPTAG_TO_STR(to_str),
participants (1)
-
Freeswitch SVN