Hi everyone, I have a SIP device that is working with RFC 2543. I am trying to send call to FreeSwitch, but none of my calls are going through. As I activated the debug on SOFIA, it returns an error as below. Can anyone help me to solve the problem? any hints? recv 660 bytes from udp/[66.220.15.230]:5060 at 18:45:21.239029: ------------------------------------------------------------------------ INVITE sip:1000@66.220.15.234 SIP/2.0 v: SIP/2.0/UDP 66.220.15.230 To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234> From: john odu <sip:26679778@66.220.15.230>;tag=4c5c58410003ac2076f6302c11fc3b7b i: 41585c4c2ba3030035e697f0a586dbaa@66.220.15.230 CSeq: 1 INVITE m: john odu <sip:26679778@66.220.15.230> Supported: com.lilo.conferencing, com.lilo.mux User-Agent: liloSipMCU/3.1.6.200801281402 c: application/sdp l: 212 v=0 o=mcu 0 0 IN IP4 66.220.15.230 s=sip:26679778@66.220.15.230 c=IN IP4 66.220.15.230 t=0 0 m=audio 2006 RTP/AVP 0 111 a=ptime:20 a=rtpmap:0 PCMU/8000 a=rtpmap:111 telephone-event/8000 a=xlilossrc:8 ------------------------------------------------------------------------ tport_deliver(0x97a1fb0): msg 0xb762bef8 (660 bytes) from udp/66.220.15.230:5060/sip next=(nil) nta: received INVITE sip:1000@66.220.15.234 SIP/2.0 (CSeq 1) nta: INVITE has bad To header nta: INVITE (1) is Bad To Header tport_tsend(0x97a1fb0) tpn = UDP/66.220.15.230:5060 tport_resolve addrinfo = 66.220.15.230:5060 tport_by_addrinfo(0x97a1fb0): not found by name UDP/66.220.15.230:5060 tport_vsend(0x97a1fb0): 239 bytes of 239 to udp/66.220.15.230:5060 tport_vsend returned 239 send 239 bytes to udp/[66.220.15.230]:5060 at 18:45:21.239369: ------------------------------------------------------------------------ SIP/2.0 400 Bad To Header Via: SIP/2.0/UDP 66.220.15.230 From: john odu <sip:26679778@66.220.15.230>;tag=4c5c58410003ac2076f6302c11fc3b7b Call-ID: 41585c4c2ba3030035e697f0a586dbaa@66.220.15.230 CSeq: 1 INVITE Content-Length: 0
everything outside the <> should be in "" On Mon, Aug 16, 2010 at 11:51 AM, Brian West <brian@freeswitch.org> wrote:
I'm pretty sure this to header is 100% invalid.
/b
On Aug 16, 2010, at 11:15 AM, Tech Micron wrote:
To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234>
_______________________________________________ FreeSWITCH-dev mailing list FreeSWITCH-dev@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-dev UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-dev http://www.freeswitch.org
-- Anthony Minessale II FreeSWITCH http://www.freeswitch.org/ ClueCon http://www.cluecon.com/ Twitter: http://twitter.com/FreeSWITCH_wire AIM: anthm MSN:anthony_minessale@hotmail.com GTALK/JABBER/PAYPAL:anthony.minessale@gmail.com IRC: irc.freenode.net #freeswitch FreeSWITCH Developer Conference sip:888@conference.freeswitch.org googletalk:conf+888@conference.freeswitch.org pstn:+19193869900
Hi Anthony, According to RFC3261 and RFC 2543, Double quote "" is not mandatory. But I have seen it in some debug traces from other SoftPhones. Ref: Section 20.39 of RFC 3261 Ref: Section 6.37 RFC 2543 The following are examples of valid To headers: To: The Operator <sip:operator@cs.columbia.edu>;tag=287447 To: sip:+12125551212@server.phone2net.com John ________________________________ From: Anthony Minessale <anthony.minessale@gmail.com> To: freeswitch-dev@lists.freeswitch.org Sent: Mon, August 16, 2010 1:15:32 PM Subject: Re: [Freeswitch-dev] Sip RFC2543 and FreeSwitch everything outside the <> should be in "" On Mon, Aug 16, 2010 at 11:51 AM, Brian West <brian@freeswitch.org> wrote:
I'm pretty sure this to header is 100% invalid.
/b
On Aug 16, 2010, at 11:15 AM, Tech Micron wrote:
To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234>
_______________________________________________ FreeSWITCH-dev mailing list FreeSWITCH-dev@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-dev UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-dev http://www.freeswitch.org
-- Anthony Minessale II FreeSWITCH http://www.freeswitch.org/ ClueCon http://www.cluecon.com/ Twitter: http://twitter.com/FreeSWITCH_wire AIM: anthm MSN:anthony_minessale@hotmail.com GTALK/JABBER/PAYPAL:anthony.minessale@gmail.com IRC: irc.freenode.net #freeswitch FreeSWITCH Developer Conference sip:888@conference.freeswitch.org googletalk:conf+888@conference.freeswitch.org pstn:+19193869900 _______________________________________________ FreeSWITCH-dev mailing list FreeSWITCH-dev@lists.freeswitch.org http://lists.freeswitch.org/mailman/listinfo/freeswitch-dev UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-dev http://www.freeswitch.org
It sure is if you have an @ sign... or you need to URL encode the value listed. /b On Aug 16, 2010, at 12:33 PM, Tech Micron wrote:
Hi Anthony,
According to RFC3261 and RFC 2543, Double quote "" is not mandatory. But I have seen it in some debug traces from other SoftPhones.
Ref: Section 20.39 of RFC 3261 Ref: Section 6.37 RFC 2543
The following are examples of valid To headers: To: The Operator <sip:operator@cs.columbia.edu>;tag=287447 To: sip:+12125551212@server.phone2net.com
John
On Mon, 16 Aug 2010, Tech Micron wrote:
Hi Anthony,
According to RFC3261 and RFC 2543, Double quote "" is not mandatory. But I have seen it in some debug traces from other SoftPhones.
Ref: Section 20.39 of RFC 3261
I am no RFC lawyer, but inter alia, that out refers to RFC 2616, and the relevant part is the description of 'tokens' in a 'field', and when certain separaters are present, must be protected in a QUOTE form http://www.ietf.org/rfc/rfc2616.txt at section 2.2 Many HTTP/1.1 header field values consist of words separated by LWS or special characters. These special characters MUST be in a quoted string to be used within a parameter value (as defined in section 3.6). token = 1*<any CHAR except CTLs or separators> separators = "(" | ")" | "<" | ">" | "@" | "," | ";" | ":" | "\" | <"> | "/" | "[" | "]" | "?" | "=" | "{" | "}" | SP | HT --------------------------- Your target string as indicated by the error message in the first post was: To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234> and the relevant unprotected section: sip:1000@66.220.15.234 contains: ":" and "@" without such quotation. I see Brian mentioned one, but it looks as though two are required to be protected A proper line might look like: To: "sip:1000@66.220.15.234" <sip:1000@66.220.15.234> -- Russ herrold
Russ, I love when someone steps up to help out like you have... Bravo. Thanks, Brian On Aug 16, 2010, at 2:59 PM, R P Herrold wrote:
I am no RFC lawyer, but inter alia, that out refers to RFC 2616, and the relevant part is the description of 'tokens' in a 'field', and when certain separaters are present, must be protected in a QUOTE form
http://www.ietf.org/rfc/rfc2616.txt at section 2.2
Many HTTP/1.1 header field values consist of words separated by LWS or special characters. These special characters MUST be in a quoted string to be used within a parameter value (as defined in section 3.6).
token = 1*<any CHAR except CTLs or separators> separators = "(" | ")" | "<" | ">" | "@" | "," | ";" | ":" | "\" | <"> | "/" | "[" | "]" | "?" | "=" | "{" | "}" | SP | HT
---------------------------
Your target string as indicated by the error message in the first post was:
To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234>
and the relevant unprotected section: sip:1000@66.220.15.234 contains: ":" and "@" without such quotation. I see Brian mentioned one, but it looks as though two are required to be protected
A proper line might look like:
To: "sip:1000@66.220.15.234" <sip:1000@66.220.15.234>
-- Russ herrold
On Mon, Aug 16, 2010 at 12:59 PM, R P Herrold <herrold@owlriver.com> wrote:
On Mon, 16 Aug 2010, Tech Micron wrote:
Hi Anthony,
According to RFC3261 and RFC 2543, Double quote "" is not mandatory. But I have seen it in some debug traces from other SoftPhones.
Ref: Section 20.39 of RFC 3261
I am no RFC lawyer, but inter alia, that out refers to RFC
Well, you may not be an RFC lawyer but you sure play one well on this list! :) -MC
If you send to more mailing lists, it doesn't mean you will get a different answer. Mike On Aug 16, 2010, at 12:15 PM, Tech Micron wrote:
Hi everyone,
I have a SIP device that is working with RFC 2543. I am trying to send call to FreeSwitch, but none of my calls are going through. As I activated the debug on SOFIA, it returns an error as below. Can anyone help me to solve the problem? any hints?
recv 660 bytes from udp/[66.220.15.230]:5060 at 18:45:21.239029: ------------------------------------------------------------------------ INVITE sip:1000@66.220.15.234 SIP/2.0 v: SIP/2.0/UDP 66.220.15.230 To: sip:1000@66.220.15.234 <sip:1000@66.220.15.234> From: john odu <sip:26679778@66.220.15.230>;tag=4c5c58410003ac2076f6302c11fc3b7b i: 41585c4c2ba3030035e697f0a586dbaa@66.220.15.230 CSeq: 1 INVITE m: john odu <sip:26679778@66.220.15.230> Supported: com.lilo.conferencing, com.lilo.mux User-Agent: liloSipMCU/3.1.6.200801281402 c: application/sdp l: 212
v=0 o=mcu 0 0 IN IP4 66.220.15.230 s=sip:26679778@66.220.15.230 c=IN IP4 66.220.15.230 t=0 0 m=audio 2006 RTP/AVP 0 111 a=ptime:20 a=rtpmap:0 PCMU/8000 a=rtpmap:111 telephone-event/8000 a=xlilossrc:8 ------------------------------------------------------------------------ tport_deliver(0x97a1fb0): msg 0xb762bef8 (660 bytes) from udp/66.220.15.230:5060/sip next=(nil) nta: received INVITE sip:1000@66.220.15.234 SIP/2.0 (CSeq 1) nta: INVITE has bad To header nta: INVITE (1) is Bad To Header tport_tsend(0x97a1fb0) tpn = UDP/66.220.15.230:5060 tport_resolve addrinfo = 66.220.15.230:5060 tport_by_addrinfo(0x97a1fb0): not found by name UDP/66.220.15.230:5060 tport_vsend(0x97a1fb0): 239 bytes of 239 to udp/66.220.15.230:5060 tport_vsend returned 239 send 239 bytes to udp/[66.220.15.230]:5060 at 18:45:21.239369: ------------------------------------------------------------------------ SIP/2.0 400 Bad To Header Via: SIP/2.0/UDP 66.220.15.230 From: john odu <sip:26679778@66.220.15.230>;tag=4c5c58410003ac2076f6302c11fc3b7b Call-ID: 41585c4c2ba3030035e697f0a586dbaa@66.220.15.230 CSeq: 1 INVITE Content-Length: 0
participants (6)
-
Anthony Minessale
-
Brian West
-
Michael Collins
-
Michael Jerris
-
R P Herrold
-
Tech Micron