[Freeswitch-users] NOT_REGISTERED error

Brian May brian at linuxpenguins.xyz
Mon Aug 1 23:20:31 UTC 2022

OK, not sure I understand, but I think I resolved some issues:

* The 1005 client had the STUN server settings enabled. But this is
  entirely within my network, without any NAT. So this setting not

  Had I known better, I would have realised that the Contact field shown
  in the registrations was showing my external IP address, not the
  internal IP address which is required.

  The USER_NOT_REGISTERED message is a red hearing, I still get that
  when it is working. Weird.

* Perhaps, just to make things more confusing the above only applies to
  IPv4, my IPv6 address was correct. Although my logs show that the 1005
  was being registered to the IPv6 profile using its IPv4 address. Huh?
  Something to do with the client I guess (zoiper). This explains why
  calls worked one way, but not the other way.

* For some reason setting zrtp_secure_media=false kills incoming
  connection handling. As in answering calls fails. Despite the fact all
  clients appear to have ZRTP disabled. Huh? I don't understand...

* Now that I have worked out these unrelated issues, to investigate the
  10 second audio problem again.

Brian May <brian at linuxpenguins.xyz> writes:

> Just quick summary of the some of the other issues:
> * Occasionally the calls just freeze. Nothing shown in freeswitch logs.
>   No sign of any packets being dropped. Just client (zoiper) freezes and
>   does nothing. I suspect this might be a client issue, maybe nothing to
>   do with freeswitch.
> * (the real problem I am trying to investigate) outgoing PSTN calls work
>   fine. But incoming calls from our VOIP provider - there is a 10+
>   second delay on all incoming audio, and I can't see any reason for
>   this. i.e. I mean I say something on remote end, wait 10 seconds, then
>   it is received at local end.
> * Turning on echo cancellation on a Linux based host running zoiper
>   seemed to cut out audio after about 1 second. So I disabled that
>   option, seems to have fixed that problem.
> Any ideas?
> -- 
> Brian May <brian at linuxpenguins.xyz>
> https://linuxpenguins.xyz/brian/
Brian May <brian at linuxpenguins.xyz>

More information about the FreeSWITCH-users mailing list