[Freeswitch-users] Bypass media mode with "intercept" application

FSX ml88888 at hotmail.com
Tue Apr 29 02:29:10 MSD 2014

I'm trying to use GV callback feature in FS and having trouble with making it
work in bypass media mode.

Incoming calls are working well. Call comes to public context, then it's
transferred to local domain context. Then it goes via:
<action application="set" data="bypass_media=true"/>
<action application="bridge" data="..."/>
RTP streams directly between remote SIP (caller party) and local SIP client,
as it should be by design (calls have better audio quality and don't use
recourses of local SIP server).

Now, I try to do the same when I use GV callback feature. Local dial plan
(as recommended in  Google Voice API
<https://wiki.freeswitch.org/wiki/Google_Voice_API>  ) sets hash with
current "uuid" and runs system call to make callback. Then in public context
dial plan incoming call is accepted, using "intercept" application with
saved "uuid". Exactly as it's recommended.

It's working well, but in this case I can't get bypass mode whatever I try
to do.
* I tried to set "bypass_media=true" before run system call to make callback
* I tried to set "bypass_media_after_bridge=true=true" before run system
call to make callback
* I tried to export those variables from leg A to incoming call (leg B)
* I tried to set it before executing "intercept" application on incoming
* I tried to apply global setting to make sure that FS is always using
bypass mode ("inbound-proxy-media" set to "true" in

Nothing works so far... FS always ignores those settings and proxies RTP

How to use bypass media mode in this scenario?

Thank you in advance

View this message in context: http://freeswitch-users.2379917.n2.nabble.com/Bypass-media-mode-with-intercept-application-tp7596078.html
Sent from the freeswitch-users mailing list archive at Nabble.com.

Join us at ClueCon 2013 Aug 6-8, 2013
More information about the FreeSWITCH-users mailing list