[Freeswitch-users] gsmopen compile error

Patrick Lists freeswitch-list at puzzled.xs4all.nl
Sun Oct 23 14:53:10 MSD 2011

On 10/23/2011 03:59 AM, Nandy Dagondon wrote:
> i tried a fresh installation to make sure there are no stale files. the
> FS build was ok and running w/ no problem.   when i build gsmopen, i
> encounter the same error.
> btw, i'm on:
> Centos 5.4 kernel 2.6.18-238.12.1.el5.
> gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-48)

I don't have a solution for your problem. But I strongly recommend that 
you update your CentOS 5.4 server to CentOS 5.7 as soon as possible. 
Your current 5.4 server has a ton of security issues and makes it 
vulnerable to root exploits. And that is never a good idea for a 
FreeSWITCH server.

All you need to do to update your server from 5.4 to 5.7 is run as root:

yum update

If you want to see how many updates this will apply then run as root:

yum list updates

More information available here:


Join us at ClueCon 2011 Aug 9-11, 2011
More information about the FreeSWITCH-users mailing list