[Freeswitch-users] T.38 reinvite and 488 Inacceptable Here relay problem; codec issue with proxy_media=true

Anthony Minessale anthony.minessale at gmail.com
Wed Mar 30 20:56:34 MSD 2011

Can you try this with the patch I just pushed to GIT.
In the future can you use JIRA for this type of report so we have a
ticket to reference the patch to?

On Wed, Mar 30, 2011 at 10:24 AM, Dmitry Sytchev <kbdfck at gmail.com> wrote:
> Hi All!
> I'm trying to launch t.38 passthough on FS.
> I have two sip profiles - local and external, one on customer side looking
> to ATAs, and one looking to PSTN gateways.
> On both profiles I have enabled t38-passthrough, and this works when T.38 is
> enabled on ATA and PSTN gateway.
> Problems come when T.38 is turned off on ATA, so PSTN gateway detects fax on
> its side and tries to re-invite ATA behind freeswitch with T.38. ATA answers
> 488 Inacceptable Here, but this answer doesn't get relayed to PSTN gateway,
> so while ATA transmits fax signals inband, PSTN gateway still doesn't know
> that re-invite is failed and fax machines can't negotiate t.30.
> My question is how to allow relay this 488 to another side of bridge?
> I thought that maybe proxy_media=true will help, and this is where second
> issue comes. I enabled late negotiation and proxy_media, the only codec I
> use is PCMA. But when I get incoming call, initially in PCMA and it goes to
> outbound ESL app via socket, in the middle of processing I get strange
> errors:
> EXECUTE sofia/external/1234567 at XXXXX.199 set(continue_on_fail=true)
> 2011-03-30 18:59:30.172363 [DEBUG] mod_dptools.c:1060
> sofia/external/1234567 at XX.XX.XX.199 SET [continue_on_fail]=[true]
> EXECUTE sofia/external/1234567 at XXXXX.199 socket(localhost:8006 async full)
> 2011-03-30 18:59:30.184605 [DEBUG] switch_ivr.c:766 Codec Activated L16 at 0hz
> 0 channels 0ms
> 2011-03-30 18:59:30.188640 [DEBUG] switch_core_session.c:954 Send signal
> sofia/external/1234567 at XXXXX.199 [BREAK]
> 2011-03-30 18:59:30.205638 [DEBUG] switch_ivr.c:563
> sofia/external/1234567 at Command Execute limit(hash
> OutboundExternalLimit 1)
> EXECUTE sofia/external/1234567 at XXXXX.199 limit(hash OutboundExternalLimit 1)
> 2011-03-30 18:59:30.205638 [INFO] switch_limit.c:126 incr called:
> OutboundExternalLimit_1 max:-1, interval:0
> 2011-03-30 18:59:30.205638 [INFO] mod_hash.c:200 Usage for
> OutboundExternalLimit_1 is now 1
> 2011-03-30 18:59:30.205638 [ERR] switch_core_io.c:724
> sofia/external/1234567 at XXXXX.199 has no write codec.
> 2011-03-30 18:59:30.205638 [DEBUG] switch_channel.c:2563
> (sofia/external/1234567 at XXXXX.199) Callstate Change RINGING -> HANGUP
> 2011-03-30 18:59:30.205638 [NOTICE] switch_core_io.c:725 Hangup
> sofia/external/1234567 at XXXXX.199 [CS_EXECUTE] [INCOMPATIBLE_DESTINATION]
> I don't answer channel in my script, it doesn't even try to execute bridge,
> failing somewhere in the middle.
> Is this a bug or misconfiguration of my FS?
> I tried latest git FreeSWITCH Version 1.0.head (git-6e78f6f 2011-03-30
> 11-41-45 +0200) with same result.
> --
> Best regards,
> Dmitry Sytchev,
> IT Engineer
> _______________________________________________
> FreeSWITCH-users mailing list
> FreeSWITCH-users at lists.freeswitch.org
> http://lists.freeswitch.org/mailman/listinfo/freeswitch-users
> UNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-users
> http://www.freeswitch.org

Anthony Minessale II

FreeSWITCH http://www.freeswitch.org/
ClueCon http://www.cluecon.com/
Twitter: http://twitter.com/FreeSWITCH_wire

AIM: anthm
MSN:anthony_minessale at hotmail.com
GTALK/JABBER/PAYPAL:anthony.minessale at gmail.com
IRC: irc.freenode.net #freeswitch

FreeSWITCH Developer Conference
sip:888 at conference.freeswitch.org
googletalk:conf+888 at conference.freeswitch.org

More information about the FreeSWITCH-users mailing list