[Freeswitch-users] originating a call from an outbound socket app

Hector Geraldino Hector.Geraldino at ip-soft.net
Thu Jun 9 17:12:49 MSD 2011

Hi all,

I've been playing with FS around weeks, with some level of success. Right now I'm stuck trying to dial an extension, or to bridge a call to an external extension. Briefly, the scenario is the following:

-          Cisco CCM forwarding SIP calls to FS

-          FS in outbound mode,  forwarding calls to a Java application using freeswitch-esl jar

The java application answers the call, says a dialogue using TTS and receives input using DTFM or speech commands; all this is working pretty well. Now I'm trying to put this call in hold, originate a call to another extension and, depending on the result (call answered, not answered, destination user presses an specific number generating an expected DTMF), I need to bridge both calls and finish the session.

I try several ways to get this done with no luck yet: using api originate to make the call with different arguments ({ignore_early_media,  etc). I even tried to skip this step and just do the bridge between the inbound call and the external extension, but this  didn't work either. I can't see any errors thrown by FS, and the result of the command is +OK, but nothing happens, the external phone never rings. The FS log only says:

[DEBUG] switch_core_session.c:954 Send signal sofia/external/5655 at [BREAK] <= this ext/IP address is from the inbound caller, not the one I'm trying to connect to.

My first impression was that I might have something wrong with the originate/bridge parameters. I changed the dialplan XML file to just do the bridge, and it worked like a charm.

<extension name="test">
        <condition field="destination_number" expression="6114|5121">
<!--    <action application="socket" data="localhost:8044 async full"/>  -->
          <action application="bridge" data="sofia/external/5562 at" />

I don't know what path to follow here. I was unable to find relevant examples on google that guides me to solve this little issue. Can somebody please give me some advice?

Thanks all,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20110609/14890ae5/attachment.html 

More information about the FreeSWITCH-users mailing list