[Freeswitch-users] mod_shout and mp3 formats

Peter P GMX Prometheus001 at gmx.net
Thu Dec 18 09:32:47 PST 2008

Today I also tried playing a wav file with the "play" application and it
worked. However accessing the same file through shout:// didn't work
with freeswitch (with Totem it worked).
The point is that FS plays the file for several seconds, but I don't
hear any sound.
I also looked at the libraries according to the wiki wiich should be
iunstalled, and they are there: Configure does not show any warnings.

Nobody has a clue what may be the problem here?

Best regards

Peter P GMX schrieb:
> I try to play mp3 I generated through Cepstral TTs and which I encoded
> via lame.
> However they won't play, so my question is: Which mp3 formats are supported?
> I generate the wav files by the following
> /opt/swift/bin/swift -n Katrin -p
> audio/channels=1,cst/f0_shift=.8,speech/rate=120,audio/sampling-rate=8000,audio/deadair=2
> -o $wavefile $text
> Then I convert to mp3 by the following variations:
> lame 46.wav 46.mp3
> lame -s 32 46.wav 46.mp3
> lame --preset 128 46.wav 46.mp3
> lame --resample 44.1 --preset 128 46.wav 46.mp3
> lame --resample 32 --preset 128 46.wav 46.mp3
> lame --resample 44.1 46.wav 46.mp3
> lame --resample 44.1 -m s --preset 128 46.wav 46.mp3
> lame --resample 44.1 -m s  46.wav 46.mp3
> lame --resample 44.1 -m s -b 128 46.wav 46.mp3
> lame --resample 44.1 -m s -B 24 46.wav 46.mp3
> lame --preset voice -v -B 64 -a 46.wav 46.mp3
> None of them worked with the playback application
> (shout://localhost/tts/46.mp3). The sound files had a length of between
> 2 and 5 sec. 2 Times during various tries they played at least
> partially. But at the next try they didn't play again. However I have a
> prerecorded sound file (44.1KHz, 128 kBits stereo music) which always
> plays well.
> The console shows me that all files are successfully played and I get a
> channel_ececute and a channel_ececute_complete after some seconds during
> event_socket. But I don't hear any sound.
> All above samples however played well with Totem on Ubuntu.
> The wiki tells me that almost any mp3 format should play. What am I
> doing wrong here?
> Another question: Should normal wav files play as well? Also with wav I
> cannot hear any sound.
> Best regards
> Peter

More information about the FreeSWITCH-users mailing list