[Freeswitch-dev] How to dial out from an existing conference?

Jean-Pierre Poulin jeanpierrepoulin at yahoo.com
Tue Mar 22 22:14:47 MSK 2011

Hi all,
I am attempting to initiate an outgoing call from a valid conference, and after 
over 10 hours of head scratching trying many things on two different builds I 
have not been able to do so.
Has anyone been able to initiate calls from conference rooms to invite another 
extension to the conference?
I have tried your suggested commands and they give me the same error messages as 

“conference dial”

According to the docs, I should be able to initiate an outgoing call to a 
registered extension with a command like “conference 3000- dial 
sofia/internal/1001 at”

My setup is as follows: 
- Latest version of the latest Freeswtich installed on Windows 7 / 64 
bit. (version reports "FreeSWITCH Version 1.0.head (git-cab1565 2010-05-18 
10-42-16 -0400)")
- All configuration settings are at their defaults, including the 
- By registering an extension 1001 with X-lite on the main computer, 
and extension 1002 on another computer, both can call each other normally and 
join conferences together and everything works great.
- Thinking this could be an X-lite issue, I have also registered 
extension 1004 on Bria on iPhone 4 and it can connect directly to the others, be 

connected by the other extensions and can connect fine to conference calls.

For my application I need Freeswitch conferences to be able to dial out to other 

registed phones.  After reading the docs, studying the dialplan, I have still 
been unable to do so after a half-day of trying various permutations and am 
currently grasping at straws… (I am currently compiling Freeswtich for Linux to 
see if it works there)

I have also tried the following commands as you suggested:
- originate sofia/internal/1004 at &conference(3300-
- originate sofia/internal/1004 at 
&conference(3300- at default)
- originate sofia/internal/1004 at conference:3300 at default inline
- originate sofia/internal/1004 at 
conference:3300- at default inline

But in all cases to any registered phones on 3 machines get an error as 
“NO_USER_RESPONSE” and “Cannot Blind Transfer 1 Legged Calls” as the log entry 
below reveals.

Should I try this whole thing in Freeswitch on Linux?


---------------------- Example log below:
freeswitch at JPM> conference 3000- dial 
sofia/internal/1002 at
2011-03-18 17:43:14.407892 [NOTICE] switch_channel.c:675 New Channel 
sofia/internal/1002 at [0b7f1ab1-2251-4bfb-946e-e5fc639a09b9]
2011-03-18 17:43:14.410892 [NOTICE] switch_channel.c:675 New Channel 
sofia/internal/0000000000 at [0a64217d-e1ff-4da8-a0b3-e84546f2e029]
2011-03-18 17:43:14.467895 [INFO] mod_dialplan_xml.c:331 Processing 
FreeSWITCH->1002 in context public
2011-03-18 17:43:14.471896 [ERR] sofia.c:5413 Cannot Blind Transfer 1 Legged 
Call Requested: result: [NO_USER_RESPONSE]
2011-03-18 17:43:14.472896 [NOTICE] sofia.c:4836 Hangup 
sofia/internal/1002 at [CS_CONSUME_MEDIA] [NO_USER_RESPONSE]
2011-03-18 17:43:14.473896 [ERR] mod_conference.c:4597 Cannot create outgoing 
channel, cause: NO_USER_RESPONSE
freeswitch at JPM> 2011-03-18 17:43:14.544900 [NOTICE] switch_core_session.c:1188 
Session 43 (sofia/internal/1002 at Ended
2011-03-18 17:43:14.544900 [NOTICE] switch_core_session.c:1190 Close Channel 
sofia/internal/1002 at [CS_DESTROY]
2011-03-18 17:43:14.570901 [NOTICE] switch_core_state_machine.c:185 
sofia/internal/0000000000 at has executed
the last dialplan instruction, hanging up.
2011-03-18 17:43:14.570901 [NOTICE] switch_core_state_machine.c:187 Hangup 
sofia/internal/0000000000 at [CS_EXECUTE] [NORMAL_CLEARING]
2011-03-18 17:43:14.572901 [NOTICE] switch_core_session.c:1188 Session 44 
(sofia/internal/0000000000 at Ended
2011-03-18 17:43:14.572901 [NOTICE] switch_core_session.c:1190 Close Channel 
sofia/internal/0000000000 at [CS_DESTROY]

More information about the FreeSWITCH-dev mailing list