[Freeswitch-dev] Issues building freeswitch (git-co) on Nexenta CP3

Thomas Haggett lists at haggett.org
Tue Aug 31 02:44:12 PDT 2010


Having run away from OpenSolaris (but not too far) I've recently migrated to Nexenta and had a go at building / running FreeSWITCH. I run a few low-throughput SIP-based projects and have thus far been running Asterisk (is that a dirty word in these parts?) on a Debian VM which horribly exploded when I tried to build on nexenta. Not being much of a fan of Asterisk, I decided to give FS a go.

For reference, my git repo HEAD is at 6cdd3e2a2e4677b061b9fbb9ee516fae9601cd16.

It wasn't a clean build, per se, but I managed it with a couple of compile non-default switches and a slight hack that I figured I'd offer back for comment / improvement;

* configure guessed my platform as "i386-pc-solaris2.11" which caused a multitude of issues, principally bad linker behaviour meaning the libtool libraries failed with gcc complaining about bad file format (or something along those lines) for the generated .lo files half way through the build, as well as some atomic lock symbols missing from the c-library which I believe are emulated in libraries for i386 processors, but present on the amd64 host. (not an expert on these things). 

These were fixed (after a while picking through non-obvious errors) by simply adding the configure arg --build=amd64-pc-solaris5.11
Apologies if this is obvious to some, but it wasn't to me and took a while to figure out.

* a couple of modules wouldn't build cleanly but because I didn't require them I just commented them out from modules.conf. Trying to be useful I tried to build as many as I could and ended up with these modules removed:
I believe a lot of these were simply missing 3rd party libraries but, since I didn't need them, I didn't spend much time working it out. I can do this if anyone is particularly interested.

* I had a couple of missing symbols (herror was one) which was simply resolved by adding LDFLAGS='-lresolv' to the configure command

* I had some issue with compiler warnings complaining about C-standards (don't have the error to hand), but I sorted this by simply adding CFLAGS='-fgnu89-inline', again to the configure.

* The only other fix was a missing definition for strcasecmp, which I struggled to sort the problem as <strings.h> was included in the appropriate files. I'm a little ashamed to say that I sorted this out by simply adding these library prototypes (lifted from strings.h) to libs/esl/src/include/esl.h:

extern int ffs(int);
extern int strcasecmp(const char *, const char *);
extern int strncasecmp(const char *, const char *, size_t);

After this the build proceeded (after quite some time) without issue and installed (and ran) fine. If anyone wants the specific errors in each case, I'll run through a build and try to reproduce and also file a bug if this is appropriate.

Now to figure out the Freeswitch configuration :)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-dev/attachments/20100831/f0b1da97/attachment-0001.html 

More information about the FreeSWITCH-dev mailing list